summaryrefslogtreecommitdiffstats
path: root/recipes-enea/partrt/partrt_1.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-10 00:31:33 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-10 00:53:44 +0200
commitcd3411088f6bb4393d79c50b5f7eef3f11a83435 (patch)
treee1b44fd7c353d9018f489d03f3dea78bc876b94a /recipes-enea/partrt/partrt_1.1.bb
downloadmeta-enea-cd3411088f6bb4393d79c50b5f7eef3f11a83435.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'recipes-enea/partrt/partrt_1.1.bb')
-rw-r--r--recipes-enea/partrt/partrt_1.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb
new file mode 100644
index 0000000..8113805
--- /dev/null
+++ b/recipes-enea/partrt/partrt_1.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "CPU partitioning tool"
2DESCRIPTION = "partrt is a tool for dividing a SMP Linux system into a real time domain and a non-real time domain."
3SECTION = "utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
6
7RDEPENDS_${PN} = "bash"
8RDEPENDS_${PN}-ptest += "python"
9
10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
11 file://run-ptest \
12 "
13
14SRCREV = "cbe36a4946a2b3bb4927ca3b8ac800111ae9ce49"
15
16inherit ptest
17
18S = "${WORKDIR}/git"
19
20FILES_${PN} += "/bin/*"
21
22do_install() {
23 install -d ${D}/usr/bin
24 install ${S}/install/bin/partrt ${D}/usr/bin
25}
26
27do_install_ptest() {
28 install ${S}/test/test_partition.py ${D}${PTEST_PATH}
29 sed -i s/target/${MACHINE}/ ${D}${PTEST_PATH}/run-ptest
30}