summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-10 00:31:33 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-10 00:53:44 +0200
commitcd3411088f6bb4393d79c50b5f7eef3f11a83435 (patch)
treee1b44fd7c353d9018f489d03f3dea78bc876b94a /conf
downloadmeta-enea-cd3411088f6bb4393d79c50b5f7eef3f11a83435.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/conf-notes.txt7
-rw-r--r--conf/distro/enea.conf64
-rw-r--r--conf/layer.conf12
-rw-r--r--conf/machine/acp3448v2.conf28
-rw-r--r--conf/machine/bsc9131rdb.conf22
-rw-r--r--conf/machine/bsc9132qds.conf20
-rw-r--r--conf/machine/ebony.conf27
-rw-r--r--conf/machine/include/tune-ppc440.inc11
-rw-r--r--conf/machine/include/tune-ppc476.inc11
-rw-r--r--conf/machine/p2020rdb-prt.conf20
-rw-r--r--conf/machine/p2041rdb-prt.conf18
11 files changed, 240 insertions, 0 deletions
diff --git a/conf/conf-notes.txt b/conf/conf-notes.txt
new file mode 100644
index 0000000..55281bd
--- /dev/null
+++ b/conf/conf-notes.txt
@@ -0,0 +1,7 @@
1Common targets are:
2 enea-image-minimal
3 enea-image-demo
4 meta-toolchain
5
6You can also run generated qemu images with a command like 'runqemu qemuppc'
7
diff --git a/conf/distro/enea.conf b/conf/distro/enea.conf
new file mode 100644
index 0000000..540aa88
--- /dev/null
+++ b/conf/distro/enea.conf
@@ -0,0 +1,64 @@
1require conf/distro/poky.conf
2DISTRO = "enea"
3DISTRO_NAME = "Enea Linux"
4DISTRO_VERSION = "4.0"
5SDK_VENDOR = "-eneasdk"
6SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
7
8MAINTAINER = "ENEA <issues@enea.com>"
9
10TARGET_VENDOR = "-enea"
11TARGET_VENDOR_virtclass-multilib-lib32 = "-enea"
12TARGET_VENDOR_virtclass-multilib-lib64 = "-enea"
13
14SANITY_TESTED_DISTROS += "\
15 CentOS-6.1 \n \
16 RedHatEnterpriseServer-6.1 \n \
17 RedHatEnterpriseServer-6.4 \n \
18 Ubuntu-12.10 \n \
19 "
20
21DISTRO_FEATURES_LIBC = "\
22 ipv4 \
23 ipv6 \
24 libc-backtrace \
25 libc-big-macros \
26 libc-bsd \
27 libc-cxx-tests \
28 libc-catgets \
29 libc-charsets \
30 libc-crypt \
31 libc-crypt-ufc \
32 libc-db-aliases \
33 libc-envz \
34 libc-fcvt \
35 libc-fmtmsg \
36 libc-fstab \
37 libc-ftraverse \
38 libc-getlogin \
39 libc-idn \
40 libc-inet-anl \
41 libc-libm \
42 libc-libm-big \
43 libc-locales \
44 libc-locale-code \
45 libc-memusage libc-nis \
46 libc-nsswitch \
47 libc-rcmd \
48 libc-rtld-debug \
49 libc-spawn \
50 libc-streams \
51 libc-sunrpc \
52 libc-utmp \
53 libc-utmpx \
54 libc-wordexp \
55 libc-posix-clang-wchar \
56 libc-posix-regexp \
57 libc-posix-regexp-glibc \
58 libc-posix-wchar-io \
59 "
60CONNECTIVITY_CHECK_URIS = " \
61 http://linux.enea.com"
62
63DISTRO_FEATURES = "ptest argp ext2 largefile xattr nfs pci multiarch ${DISTRO_FEATURES_LIBC} "
64BB_DANGLINGAPPENDS_WARNONLY ?= "1"
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..bfd4ef2
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a packages directory, add to BBFILES
2BBPATH .= ":${LAYERDIR}"
3
4BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*"
5BBFILES += "${LAYERDIR}/images/*.bb*"
6
7BBFILE_COLLECTIONS += "enea"
8BBFILE_PATTERN_enea := "^${LAYERDIR}/"
9BBFILE_PRIORITY_enea = "6"
10
11BB_ENV_EXTRAWHITE := "KSRC USRC"
12BB_DANGLINGAPPENDS_WARNONLY = "yes"
diff --git a/conf/machine/acp3448v2.conf b/conf/machine/acp3448v2.conf
new file mode 100644
index 0000000..7fa628f
--- /dev/null
+++ b/conf/machine/acp3448v2.conf
@@ -0,0 +1,28 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require include/tune-ppc476.inc
5
6MACHINE_FEATURES = "usbhost pci ext2 ext3"
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux"
9PREFERRED_VERSION_virtual/kernel ?= "3.0.6"
10
11PREFERRED_PROVIDER_linux-libc-headers ?= "linux-kernel-headers"
12PREFERRED_PROVIDER_linux-libc-headers-nativesdk ?= "linux-kernel-headers-nativesdk"
13PREFERRED_VERSION_linux-kernel-headers ?= "3.0.6"
14PREFERRED_VERSION_linux-kernel-headers-nativesdk ?= "3.0.6"
15
16KERNEL_EXTRA_OEMAKE = "V=1"
17#KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/acp.dts"
18#KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/acp_dbgconfig"
19KERNEL_IMAGETYPE = "uImage"
20UBOOT_ENTRYPOINT = "0x00400000"
21UBOOT_LOADADDRESS = "0x00400000"
22IMAGE_FSTYPES = "tar.gz ext2.gz ext2.gz.u-boot"
23USE_VT = "0"
24SERIAL_CONSOLE = "115200 ttyS0"
25
26# override version preference in tcmode-default.inc
27#PREFERRED_VERSION_u-boot-mkimage-native_powerpc = ""
28
diff --git a/conf/machine/bsc9131rdb.conf b/conf/machine/bsc9131rdb.conf
new file mode 100644
index 0000000..72a4532
--- /dev/null
+++ b/conf/machine/bsc9131rdb.conf
@@ -0,0 +1,22 @@
1TARGET_FPU = "ppc-efd"
2
3require conf/machine/include/tune-ppce500v2.inc
4
5MACHINE_FEATURES = "kernel26 pci ext2 ext3 serial"
6MACHINE_EXTRA_RRECOMMENDS = ""
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-bsc913x"
9PREFERRED_VERSION_virtual/kernel ?= "2.6.33"
10PREFERRED_PROVIDER_linux-libc-headers ?= "linux-bsc913x-headers"
11PREFERRED_PROVIDER_linux-libc-headers-nativesdk ?= "linux-bsc913x-headers-nativesdk"
12
13KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/bsc9131rdb.dts"
14
15KERNEL_IMAGETYPE ?= "uImage"
16# disable the images below for now
17# ext2.bz2 ext2.lzma \
18# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
19
20MACHINEOVERRIDES .= ":e500v2"
21SERIAL_CONSOLE = "115200 ttyS0"
22USE_VT = "0"
diff --git a/conf/machine/bsc9132qds.conf b/conf/machine/bsc9132qds.conf
new file mode 100644
index 0000000..1c4aab3
--- /dev/null
+++ b/conf/machine/bsc9132qds.conf
@@ -0,0 +1,20 @@
1TARGET_FPU = "ppc-efd"
2
3require conf/machine/include/tune-ppce500v2.inc
4
5MACHINE_FEATURES = "kernel26 pci ext2 ext3 serial"
6MACHINE_EXTRA_RRECOMMENDS = ""
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-bsc913x"
9PREFERRED_VERSION_virtual/kernel ?= "2.6.33"
10PREFERRED_PROVIDER_linux-libc-headers ?= "linux-bsc913x-headers"
11PREFERRED_PROVIDER_linux-libc-headers-nativesdk ?= "linux-bsc913x-headers-nativesdk"
12
13KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/bsc9132qds.dts"
14
15KERNEL_IMAGETYPE ?= "uImage"
16# disable the images below for now
17# ext2.bz2 ext2.lzma \
18# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
19
20MACHINEOVERRIDES .= ":e500v2"
diff --git a/conf/machine/ebony.conf b/conf/machine/ebony.conf
new file mode 100644
index 0000000..25734be
--- /dev/null
+++ b/conf/machine/ebony.conf
@@ -0,0 +1,27 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require include/tune-ppc440.inc
5
6PREFERRED_PROVIDER_virtual/kernel ?= "kernel-org"
7PREFERRED_VERSION_kernel-org ?= "3.0.6"
8
9PREFERRED_PROVIDER_linux-libc-headers ?= "kernel-org-headers"
10PREFERRED_PROVIDER_linux-libc-headers-nativesdk ?= "kernel-org-headers-nativesdk"
11
12PREFERRED_VERSION_kernel-org-headers ?= "3.0.6"
13PREFERRED_VERSION_kernel-org-headers-nativesdk ?= "3.0.6"
14
15#PREFERRED_VERSION_linx = "2.6.3"
16#PREFERRED_VERSION_linx-mod = "2.6.3"
17
18IMAGE_FSTYPES = "tar.gz ext2.gz ext2.gz.u-boot"
19
20UBOOT_MACHINES = "ebony_config"
21KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/ebony.dts"
22KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/44x/ebony_defconfig"
23KERNEL_IMAGETYPE = "uImage"
24MACHINE_FEATURES = "kernel26 ext3 serial"
25
26# override version preference in tcmode-default.inc
27PREFERRED_VERSION_u-boot-mkimage-native_powerpc = ""
diff --git a/conf/machine/include/tune-ppc440.inc b/conf/machine/include/tune-ppc440.inc
new file mode 100644
index 0000000..6262fb7
--- /dev/null
+++ b/conf/machine/include/tune-ppc440.inc
@@ -0,0 +1,11 @@
1DEFAULTTUNE ?= "ppc440"
2
3require conf/machine/include/powerpc/arch-powerpc.inc
4
5TUNEVALID[ppc440] = "Enable ppc440 specific processor optimizations"
6TUNE_CCARGS += "${@bb.utils.contains("TUNE_FEATURES", "ppc440", "-mcpu=440", "", d)}"
7TUNE_PKGARCH = "${@bb.utils.contains("TUNE_FEATURES", "ppc440", "ppc440", "", d)}"
8
9AVAILTUNES = "ppc440"
10TUNE_FEATURES_tune-ppc440 = "m32 fpu-soft ppc440"
11PACKAGE_EXTRA_ARCHS_tune-ppc440 = "powerpc-nf ppc440 ppc405"
diff --git a/conf/machine/include/tune-ppc476.inc b/conf/machine/include/tune-ppc476.inc
new file mode 100644
index 0000000..a34690f
--- /dev/null
+++ b/conf/machine/include/tune-ppc476.inc
@@ -0,0 +1,11 @@
1DEFAULTTUNE ?= "ppc476"
2
3require conf/machine/include/powerpc/arch-powerpc.inc
4
5AVAILTUNES += "ppc476"
6TUNE_FEATURES_tune-ppc476 = "m32 fpu-hard ppc476"
7TUNEVALID[ppc476] = "Enable ppc476 specific processor optimizations"
8TUNE_CCARGS += "${@bb.utils.contains("TUNE_FEATURES", "ppc476", "-mcpu=476", "", d)}"
9TUNE_PKGARCH_tune-ppc476 = "ppc476"
10
11PACKAGE_EXTRA_ARCHS_tune-ppc476 = "powerpc-nf ppc476 ppc440 ppc405"
diff --git a/conf/machine/p2020rdb-prt.conf b/conf/machine/p2020rdb-prt.conf
new file mode 100644
index 0000000..55eccdf
--- /dev/null
+++ b/conf/machine/p2020rdb-prt.conf
@@ -0,0 +1,20 @@
1#@TYPE: Machine
2#@Name: Freescale P2020RDB
3#@DESCRIPTION: Machine configuration for the Freescale P2020RDB with Preempt-RT enabled
4
5require conf/machine/e500v2.inc
6require conf/machine/include/soc-family.inc
7
8SOC_FAMILY = "p2020"
9BOOTFORMAT_CONFIG = "config_sram_p1022ds.dat"
10UBOOT_MACHINES ?= " P2020RDB-PC P2020RDB-PC_NAND P2020RDB-PC_SDCARD P2020RDB-PC_SPIFLASH P2020RDB-PC_36BIT P2020RDB-PC_36BIT_SPIFLASH P2020RDB-PC_36BIT_NAND P2020RDB-PC_36BIT_SDCARD"
11KERNEL_DEVICETREE ?= "p2020rdb-pc_32b.dtb"
12KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
13
14PREFERRED_PROVIDER_virtual/kernel = "linux-qoriq-sdk-prt"
15
16JFFS2_ERASEBLOCK = "0x20000"
17
18SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
19SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
20USE_VT = "0"
diff --git a/conf/machine/p2041rdb-prt.conf b/conf/machine/p2041rdb-prt.conf
new file mode 100644
index 0000000..3172a56
--- /dev/null
+++ b/conf/machine/p2041rdb-prt.conf
@@ -0,0 +1,18 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running with preempt-RT enabled
3
4require conf/machine/e500mc.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p2041"
8UBOOT_MACHINES ?= "P2041RDB P2041RDB_NAND P2041RDB_SECURE_BOOT P2041RDB_SDCARD P2041RDB_SPIFLASH"
9KERNEL_DEVICETREE ?= "p2041rdb.dtb p2041rdb-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
11
12PREFERRED_PROVIDER_virtual/kernel = "linux-qoriq-sdk-prt"
13
14JFFS2_ERASEBLOCK = "0x10000"
15
16SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
17SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
18USE_VT = "0"