summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_4.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.1.bbappend')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bbappend33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bbappend b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
new file mode 100644
index 0000000..6f1fcc2
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
@@ -0,0 +1,33 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_t4240rdb-64b = " file://dts/t4240rdb-usdpaa-enea.dts"
4SRC_URI_append_p2041rdb = " file://dts/p2041rdb-usdpaa-enea.dts"
5SRC_URI_append_p3041ds = " file://dts/p3041ds-usdpaa-enea.dts"
6
7KERNEL_DEVICETREE_append_t4240rdb-64b = " t4240rdb-usdpaa-enea.dtb"
8KERNEL_DEVICETREE_append_p2041rdb = " p2041rdb-usdpaa-enea.dtb"
9KERNEL_DEVICETREE_append_p3041ds = " p3041ds-usdpaa-enea.dtb"
10
11ENEA_KERNEL_FRAGMENTS_append = " \
12 cfg/uio_fsl_srio.cfg \
13 cfg/rcu_boost.cfg \
14 cfg/rcu_nocb.cfg \
15 cfg/debug_off.cfg \
16 cfg/profiling_off.cfg \
17 cfg/rt_lld.cfg \
18 cfg/nohz.cfg \
19 cfg/hotplug_cpu.cfg \
20 cfg/ppc/erratum_off.cfg \
21 "
22
23do_configure_prepend_t4240rdb-64b() {
24 cp ${WORKDIR}/dts/t4240rdb-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
25}
26
27do_configure_prepend_p2041rdb() {
28 cp ${WORKDIR}/dts/p2041rdb-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
29}
30
31do_configure_prepend_p3041ds() {
32 cp ${WORKDIR}/dts/p3041ds-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
33}