summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/dpdk/dpdk_16.11.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_16.11.bbappend b/recipes-extended/dpdk/dpdk_16.11.bbappend
new file mode 100644
index 0000000..f536065
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_16.11.bbappend
@@ -0,0 +1,19 @@
1COMPATIBLE_MACHINE_inteld1521 = "inteld1521"
2
3# Overrides the default value set to DPDK_TARGET_MACH in dpdk.inc,
4# with the purpose adding 'inteld1521' to 'multiarch_options'
5export DPDK_TARGET_MACH = "${@get_dpdk_target(bb,d)}"
6
7def get_dpdk_target(bb, d):
8 target_arch = d.getVar('MACHINE_ARCH', True)
9 multiarch_options = {
10 "mohonpeak64":"atm",
11 "mohonpeak32":"atm",
12 "crystalforest": "ivb",
13 "intel_corei7_64": "hsw",
14 "inteld1521": "hsw",
15 }
16
17 if target_arch in multiarch_options :
18 return multiarch_options[target_arch]
19 return ""