summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-11-18 13:38:52 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2016-11-18 13:38:52 +0100
commit8cbcad3e07c9ac2ffb539248f2eaeb0c49379fb8 (patch)
tree5c3e6edfc04ce953e29591958839ae0daf219a23
downloadmeta-enea-bsp-x86-8cbcad3e07c9ac2ffb539248f2eaeb0c49379fb8.tar.gz
Initialize layer
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--COPYING.MIT17
-rw-r--r--README58
-rw-r--r--conf/layer.conf12
3 files changed, 87 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..89de354
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/README b/README
new file mode 100644
index 0000000..1c97af9
--- /dev/null
+++ b/README
@@ -0,0 +1,58 @@
1meta-enea-bsp-x86
2===================================================================
3
4This layer contains Enea BSP customizations for x86 architecures.
5
6Dependencies
7============
8
9This layer depends on:
10
11 URI: git://git.enea.com/linux/meta-enea-bsp-common
12 branch: master
13 revision: HEAD
14
15Source code
16===========
17
18git://git.enea.com/linux/meta-enea-bsp-x86.git
19
20
21Patches
22=======
23
24Please submit any patches against the enea-bsp-x86 layer to the
25following mailing list: linux@lists.enea.com
26
27Maintainers:
28Adrian Dudau <adrian.dudau@enea.com>
29Martin Borg <martin.borg@enea.com>
30
31
32Table
33=================
34
35 I. Adding the enea-bsp-x86 layer to your build
36 II. Misc
37
38
39I. Adding the enea-bsp-x86 layer to your build
40=================================================
41
42In order to use this layer, you need to make the build system aware of
43it.
44
45Assuming the enea-bsp-x86 layer exists at the top-level of your
46yocto build tree, you can add it to the build system by adding the
47location of the enea-bsp-x86 layer to bblayers.conf, along with any
48other layers needed. e.g.:
49
50
51 BBLAYERS ?= " \
52 /path/to/yocto/meta \
53 /path/to/yocto/meta-poky \
54 /path/to/yocto/meta-enea-bsp-common \
55 "
56
57II. Misc
58========
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..da41ab2
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/packagegroups/* \
7 ${LAYERDIR}/recipes-*/*/*.bbappend"
8
9BBFILE_COLLECTIONS += "enea-bsp-x86"
10BBFILE_PATTERN_enea-bsp-x86 = "^${LAYERDIR}/"
11BBFILE_PRIORITY_enea-bsp-x86 = "6"
12LAYERDEPENDS_enea-bsp-x86 = "enea-bsp-common"