summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Calianu <adrian.calianu@enea.com>2016-12-29 15:34:12 +0100
committerAdrian Calianu <adrian.calianu@enea.com>2016-12-29 15:34:12 +0100
commit19c230d81a4c8bb4ea9d53cf14a6d86871e5237a (patch)
tree96619b9e5f0f056690718f89d70925483d19103e
parent1e1a39992540f5026b02819ba91c072ee16e61d3 (diff)
downloadmeta-enea-bsp-x86-19c230d81a4c8bb4ea9d53cf14a6d86871e5237a.tar.gz
dpdk: add support for qemux86-64
Since qemux86-64 is based on core2 64bit architecture it should be possible to run dpdk on it. Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
-rw-r--r--recipes-extended/dpdk/dpdk_16.11.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_16.11.bbappend b/recipes-extended/dpdk/dpdk_16.11.bbappend
index f536065..fe25646 100644
--- a/recipes-extended/dpdk/dpdk_16.11.bbappend
+++ b/recipes-extended/dpdk/dpdk_16.11.bbappend
@@ -1,4 +1,7 @@
1COMPATIBLE_MACHINE_inteld1521 = "inteld1521" 1COMPATIBLE_MACHINE_inteld1521 = "inteld1521"
2COMPATIBLE_MACHINE_qemux86-64 = "qemux86-64"
3
4export RTE_TARGET="${@bb.utils.contains("TUNE_FEATURES", "m64", "x86_64-native-linuxapp-gcc", "i686-native-linuxapp-gcc", d)}"
2 5
3# Overrides the default value set to DPDK_TARGET_MACH in dpdk.inc, 6# Overrides the default value set to DPDK_TARGET_MACH in dpdk.inc,
4# with the purpose adding 'inteld1521' to 'multiarch_options' 7# with the purpose adding 'inteld1521' to 'multiarch_options'
@@ -12,6 +15,7 @@ def get_dpdk_target(bb, d):
12 "crystalforest": "ivb", 15 "crystalforest": "ivb",
13 "intel_corei7_64": "hsw", 16 "intel_corei7_64": "hsw",
14 "inteld1521": "hsw", 17 "inteld1521": "hsw",
18 "qemux86_64": "default",
15 } 19 }
16 20
17 if target_arch in multiarch_options : 21 if target_arch in multiarch_options :