summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-qoriq-common.inc9
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bbappend26
2 files changed, 6 insertions, 29 deletions
diff --git a/recipes-kernel/linux/linux-qoriq-common.inc b/recipes-kernel/linux/linux-qoriq-common.inc
index eca33c7..958ab03 100644
--- a/recipes-kernel/linux/linux-qoriq-common.inc
+++ b/recipes-kernel/linux/linux-qoriq-common.inc
@@ -47,13 +47,16 @@ KERNEL_DEVICETREE_append_p3041ds = " p3041ds-usdpaa-enea.dtb"
47 47
48require recipes-kernel/linux/pramfs-3.12.inc 48require recipes-kernel/linux/pramfs-3.12.inc
49 49
50# Freescale looks for cfg fragments within the build directory, so
51# they must be copied there before running do_configure_prepend()
52# task
50do_unpack_append() { 53do_unpack_append() {
51 import shutil 54 import shutil
52 workdir = d.getVar("WORKDIR", True) 55 workdir = d.getVar("WORKDIR", True)
53 sourcedir = d.getVar("S", True) 56 builddir = d.getVar("B", True)
54 bb.note("Copy cfg folder from workdir %s to source directory %s" % (workdir, sourcedir)) 57 bb.note("Copy cfg folder from workdir %s to build directory %s" % (workdir, builddir))
55 src = workdir + "/cfg" 58 src = workdir + "/cfg"
56 dst = sourcedir + "/cfg" 59 dst = builddir + "/cfg"
57 try: 60 try:
58 shutil.copytree(src, dst) 61 shutil.copytree(src, dst)
59 except shutil.Error as e: 62 except shutil.Error as e:
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
index 67afd97..f9311e9 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
@@ -1,27 +1 @@
1require recipes-kernel/linux/linux-qoriq-common.inc require recipes-kernel/linux/linux-qoriq-common.inc
2
3do_configure_prepend() {
4 # copy desired defconfig so we pick it up for the real kernel_do_configure
5 cp ${KERNEL_DEFCONFIG} ${B}/.config
6
7 # add config fragments
8 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
9 if [ -f "${WORKDIR}/${deltacfg}" ]; then
10 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
11 elif [ -f "${S}/arch/powerpc/configs/${deltacfg}" ]; then
12 ${S}/scripts/kconfig/merge_config.sh -m .config \
13 ${S}/arch/powerpc/configs/${deltacfg}
14 fi
15 done
16
17 #add git revision to the local version
18 if [ "${SCMVERSION}" = "y" ]; then
19 # append sdk version if SDK_VERSION is defined
20 sdkversion=''
21 if [ -n "${SDK_VERSION}" ]; then
22 sdkversion="-${SDK_VERSION}"
23 fi
24 head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
25 printf "%s%s%s" $sdkversion +g $head > ${B}/.scmversion
26 fi
27}