summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bbappend b/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bbappend
new file mode 100644
index 0000000..128bb41
--- /dev/null
+++ b/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bbappend
@@ -0,0 +1,7 @@
1# Remove RGMII port since it is allocated to Linux stack when boot with -usdpaa-enea- device tree
2# Removed port must always match with the one removed from -usdpaa-enea-
3
4do_configure_prepend() {
5 sed '/type=\"MAC\" number=\"5\"/d' ${S}/src/ppac/usdpaa_config_p2_p3_p5_14g.xml > ${S}/src/ppac/usdpaa_config_enea_p2_p3_p5_14g.xml
6 sed '/usdpaa_config_p2_p3_p5_14g\.xml/a\ usdpaa_config_enea_p2_p3_p5_14g.xml \\' ${S}/src/ppac/Makefile.am > ${S}/src/ppac/Makefile.am.bak && mv ${S}/src/ppac/Makefile.am.bak ${S}/src/ppac/Makefile.am
7}