summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-proliant-m400.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-proliant-m400.bb')
-rw-r--r--recipes-kernel/linux/linux-proliant-m400.bb97
1 files changed, 0 insertions, 97 deletions
diff --git a/recipes-kernel/linux/linux-proliant-m400.bb b/recipes-kernel/linux/linux-proliant-m400.bb
deleted file mode 100644
index 8bada19..0000000
--- a/recipes-kernel/linux/linux-proliant-m400.bb
+++ /dev/null
@@ -1,97 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for HP Moonshot m400"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6COMPATIBLE_MACHINE = "proliant-m400"
7
8inherit kernel siteinfo
9require recipes-kernel/linux/linux-dtb.inc
10
11MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
12PR = "${MACHINE_KERNEL_PR}"
13
14KERNEL_DEVICETREE = "arch/${ARCH}/boot/dts/proliant-m400.dts"
15
16SRCREV = "485659fab442882158cb3a007215e89529b987a3"
17BRANCH = "Ubuntu-3.13.0-29.53"
18SRC_URI = "git://kernel.ubuntu.com/dannf/trusty-xgene.git;protocol=git \
19 file://hpconfig \
20 file://defconfig \
21 file://proliant-m400.dts \
22 file://cfg/00027-lttng.cfg \
23 file://cfg/00028-perf.cfg \
24 file://cfg/00025-powertop.cfg \
25 file://cfg/00004-systemtap.cfg \
26 "
27
28require kernel-configure.inc
29KERNEL_FEATURES = "\
30 cfg/00027-lttng.cfg \
31 cfg/00028-perf.cfg \
32 cfg/00025-powertop.cfg \
33 cfg/00004-systemtap.cfg \
34 "
35
36DEPENDS += "libgcc u-boot-mkimage-native"
37
38S = "${WORKDIR}/git"
39
40# KERNEL_LOCALVERSION can be set to add a tag to the end of the
41# kernel version string. such as the commit id
42KERNEL_LOCALVERSION ?= ""
43
44# Check the defconfig file and see if it points to an in kernel
45# defconfig that should be used, or if it is a complete config file
46
47addtask setup_defconfig before do_configure after do_patch
48do_setup_defconfig() {
49 cp ${WORKDIR}/proliant-m400.dts ${S}/arch/arm64/boot/dts/proliant-m400.dts
50
51 # Always copy the defconfig file to .config to keep consistency
52 # between the case where there is a real config and the in kernel
53 # tree config
54 cp ${WORKDIR}/hpconfig ${S}/arch/arm64/configs/hpconfig_defconfig
55 cp ${WORKDIR}/defconfig ${S}/.config
56
57 configure_kernel "${S}/.config" "${KERNEL_FEATURES}"
58}
59
60# define our own do_configure that will:
61# 1. Check the .config file and see if string use-kernel-config= is present
62# 2. If the use-kernel-config string is present parse out the config to use
63# and run make ${config}
64# 3. else run yes '' | oe_runmake oldconfig like the default do_configure
65# does
66do_configure() {
67 echo ${KERNEL_LOCALVERSION} > ${B}/.scmversion
68 echo ${KERNEL_LOCALVERSION} > ${S}/.scmversion
69 config=`cat ${S}/.config | grep use-kernel-config | cut -d= -f2`
70 if [ "x${config}" != "x" ]
71 then
72 oe_runmake ${config}
73 else
74 yes '' | oe_runmake oldconfig
75 fi
76}
77
78
79# Force uImage build, no support for doing it in do_compile in arm64 arch
80do_uboot_mkimage() {
81 local ENTRYPOINT=${UBOOT_ENTRYPOINT}
82 if test -n "${UBOOT_ENTRYSYMBOL}"; then
83 ENTRYPOINT=`${HOST_PREFIX}nm ${S}/vmlinux | \
84 awk '$3=="${UBOOT_ENTRYSYMBOL}" {print $1}'`
85 fi
86 uboot-mkimage -A ${UBOOT_ARCH} -O linux -T kernel -C none -a ${UBOOT_LOADADDRESS} -e ${ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d arch/${ARCH}/boot/Image arch/${ARCH}/boot/uImage
87}
88
89
90do_deploy_append() {
91 local readonly KERNEL_UIMAGE_BASE_NAME="uImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
92 local readonly KERNEL_UIMAGE_SYMLINK_NAME="uImage-${MACHINE}"
93
94 install -m 0644 arch/${ARCH}/boot/uImage ${DEPLOYDIR}/${KERNEL_UIMAGE_BASE_NAME}.bin
95 ln -sf ${KERNEL_UIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/${KERNEL_UIMAGE_SYMLINK_NAME}.bin
96 ln -sf ${KERNEL_UIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/uImage
97}