summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-boundary_3.10.17.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-boundary_3.10.17.bbappend')
-rw-r--r--recipes-kernel/linux/linux-boundary_3.10.17.bbappend31
1 files changed, 0 insertions, 31 deletions
diff --git a/recipes-kernel/linux/linux-boundary_3.10.17.bbappend b/recipes-kernel/linux/linux-boundary_3.10.17.bbappend
deleted file mode 100644
index 3e6b61d..0000000
--- a/recipes-kernel/linux/linux-boundary_3.10.17.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append = "file://cfg/00014-kgdb.cfg \
4 file://cfg/00027-lttng.cfg \
5 file://cfg/00028-perf.cfg \
6 file://cfg/00025-powertop.cfg \
7 file://cfg/00004-systemtap.cfg \
8 file://cfg/00003-fuse.cfg \
9 file://cfg/00034-cpusets.cfg \
10 file://cfg/00030-latencytop.cfg \
11 file://cfg/00022-mtd_tests.cfg \
12 "
13#
14# The linux-boundary recipe doesn't implement a method to merge config fragments
15# to the kernel config file, so we need to implement it ourselves.
16#
17
18# returns all the elements from the src uri that are kernel config files
19def find_cfgs(d):
20 sources=src_patches(d, True)
21 sources_list=[]
22 for s in sources:
23 base, ext = os.path.splitext(os.path.basename(s))
24 if ext and ext in ".cfg":
25 sources_list.append(s)
26 return sources_list
27
28# apply kernel configs from the src uri
29kernel_do_configure_prepend() {
30 ${S}/scripts/kconfig/merge_config.sh -m ${S}/.config ${@" ".join(find_cfgs(d))}
31}