summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-ls1_3.12.bbappend
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-06-08 14:44:13 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-06-09 17:04:01 +0200
commit92f7911635dfe561484b7aa9df513d34d204559a (patch)
tree6bf9e48dc995279be558a72354ef10e3e8a03870 /recipes-kernel/linux/linux-ls1_3.12.bbappend
parent1d66379144ea6cc28ef5e9b9fe841158b0011774 (diff)
downloadmeta-enea-bsp-arm-92f7911635dfe561484b7aa9df513d34d204559a.tar.gz
linux-ls1: Apply kernel configs
Aplpy the same kernel configs as for the qoriq kernel. meta-fsl-arm has a class overwriting the .config file in do_configure_prepend which makes it impossible to make changes to it in a .bbappend. So we are forced to change it in do_configure_append and force another configuration. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-kernel/linux/linux-ls1_3.12.bbappend')
-rw-r--r--recipes-kernel/linux/linux-ls1_3.12.bbappend29
1 files changed, 28 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ls1_3.12.bbappend b/recipes-kernel/linux/linux-ls1_3.12.bbappend
index 338b3bf..e8fd2e4 100644
--- a/recipes-kernel/linux/linux-ls1_3.12.bbappend
+++ b/recipes-kernel/linux/linux-ls1_3.12.bbappend
@@ -1,3 +1,5 @@
1require linux-ls1-common.inc
2
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 4
3SRC_URI += "file://ls1021aiot.dts \ 5SRC_URI += "file://ls1021aiot.dts \
@@ -8,5 +10,30 @@ SRC_URI += "file://ls1021aiot.dts \
8ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" 10ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
9 11
10do_configure_prepend() { 12do_configure_prepend() {
11 cp -rf ${WORKDIR}/ls1021aiot.dts ${S}/arch/arm/boot/dts/ls1021aiot.dts 13 cp -rf ${WORKDIR}/ls1021aiot.dts ${S}/arch/arm/boot/dts/ls1021aiot.dts
14}
15
16do_configure_append() {
17 #
18 # Add Enea specific kernel configs
19 #
20
21 #gather full config fragment paths
22 addon_features=""
23 if [ -n "${ENEA_KERNEL_FRAGMENTS}" ]; then
24 for feature in ${ENEA_KERNEL_FRAGMENTS}; do
25 addon_features="${addon_features} ${WORKDIR}/${feature}"
26 done
27 fi
28
29 #in case there is no .config file yet
30 touch ${B}/.config
31
32 if [ -e "${S}/scripts/kconfig/merge_config.sh" ]; then
33 O=${B} ${S}/scripts/kconfig/merge_config.sh -m .config ${addon_features}
34 else
35 bbfatal "No merge_config.sh found in the kernel tree."
36 fi
37
38 oe_runmake KCONFIG_ALLCONFIG=${B}/.config O=${B} alldefconfig
12} 39}