summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2015-11-02 10:57:44 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2015-11-02 11:20:41 +0100
commita130fba56f34391c7e921b2e2fd2ba174002e6a5 (patch)
tree5f50afba2f2ff1f9f524e8cb7c24b90b8212cb77 /conf
downloadmeta-enea-bsp-arm-a130fba56f34391c7e921b2e2fd2ba174002e6a5.tar.gz
Initial commit
result of splitting up meta-enea Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf12
-rw-r--r--conf/machine/include/arch-armv8.inc20
-rw-r--r--conf/machine/proliant-m400.conf23
3 files changed, 55 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..ef5f722
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/images/* \
7 ${LAYERDIR}/packagegroups/* \
8 ${LAYERDIR}/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS += "enea-bsp-arm"
11BBFILE_PATTERN_enea-bsp-arm = "^${LAYERDIR}/"
12BBFILE_PRIORITY_enea-bsp-arm = "6"
diff --git a/conf/machine/include/arch-armv8.inc b/conf/machine/include/arch-armv8.inc
new file mode 100644
index 0000000..c86142a
--- /dev/null
+++ b/conf/machine/include/arch-armv8.inc
@@ -0,0 +1,20 @@
1DEFAULTTUNE ?= "aarch64"
2
3ARMPKGARCH ?= "aarch64"
4
5TUNEVALID[aarch64] = "Enable instructions for aarch64"
6TUNEVALID[bigendian] = "Enable big-endian mode."
7TUNECONFLICTS[aarch64] = ""
8MACHINEOVERRIDES .= "${@bb.utils.contains("TUNE_FEATURES", "aarch64", ":aarch64", "" ,d)}"
9
10# Little Endian base configs
11AVAILTUNES += "aarch64 aarch64_be"
12TUNE_FEATURES_tune-aarch64 ?= "aarch64"
13TUNE_FEATURES_tune-aarch64_be ?= "${TUNE_FEATURES_tune-aarch64} bigendian"
14
15ARMPKGSFX_ENDIAN = "${@bb.utils.contains("TUNE_FEATURES", "bigendian", "_be", "", d)}"
16
17TUNE_ARCH = "aarch64${ARMPKGSFX_ENDIAN}"
18TUNE_PKGARCH = "aarch64${ARMPKGSFX_ENDIAN}"
19
20PACKAGE_EXTRA_ARCHS = "aarch64${ARMPKGSFX_ENDIAN}"
diff --git a/conf/machine/proliant-m400.conf b/conf/machine/proliant-m400.conf
new file mode 100644
index 0000000..f9a2170
--- /dev/null
+++ b/conf/machine/proliant-m400.conf
@@ -0,0 +1,23 @@
1#@TYPE: Machine
2#@NAME: Moonshot ProLiant m400
3#@DESCRIPTION: Machine configuration for HP Proliant m400
4
5require conf/machine/include/arch-armv8.inc
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-proliant-m400"
8
9UBOOT_ENTRYPOINT = "0x00080000"
10UBOOT_LOADADDRESS = "0x00080000"
11
12MACHINE_FEATURES = "pci ext2 ext3 serial"
13
14RDEPENDS_kernel-base = "kernel-image"
15
16KERNEL_IMAGETYPE = "Image"
17
18SERIAL_CONSOLES = "115200;ttyS0 115200;ttyAMA0"
19
20# we do not want to have getty running since we do not have a
21# graphical display attached and therefore do not need virtual
22# terminal functionality
23USE_VT = "0"