summaryrefslogtreecommitdiffstats
path: root/recipes-core/systemd/systemd_247.6.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd/systemd_247.6.bbappend')
-rw-r--r--recipes-core/systemd/systemd_247.6.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd_247.6.bbappend b/recipes-core/systemd/systemd_247.6.bbappend
new file mode 100644
index 0000000..eb2b118
--- /dev/null
+++ b/recipes-core/systemd/systemd_247.6.bbappend
@@ -0,0 +1,25 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_sota = " file://basic.conf.in"
4
5GROUPADD_PARAM_${PN}_append_sota = "; -r render"
6
7# systemd uses certain groups unless configured not to (e.g. journal logs are more
8# broadly available to the 'wheel' group unless told otherwise), while some resources
9# are using to the 'nobody' group. Configure systemd to:
10# - not use the 'wheel' group (journal access will be restriced to root user);
11# - use the proper group for 'nobody', which should have GID 65534 (for NFVA 'nogroup');
12EXTRA_OEMESON += " \
13 -Dwheel-group=false \
14 -Dnobody-group=nogroup \
15"
16
17do_configure_prepend_sota() {
18 cp ${WORKDIR}/basic.conf.in ${S}/sysusers.d/basic.conf.in
19}
20
21do_install_append () {
22 # Update default udev rules for /dev/kvm to be less permissive
23 sed -e 's/\(KERNEL=="kvm".*\)0666/\10660/' \
24 -i ${D}${rootlibexecdir}/udev/rules.d/50-udev-default.rules
25}