summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2021-03-24 11:58:07 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2021-03-25 12:27:30 +0100
commit5f980c14dafb466e1d71e0b6e7487aa522ade9f9 (patch)
tree0d58f2aea15998482c8baed3510964bfba292cfd
parent23ed226a4b4b7c1cac2c52e6808631d9f0d6f652 (diff)
downloadmeta-el-nfv-access-5f980c14dafb466e1d71e0b6e7487aa522ade9f9.tar.gz
Upgrade to gatesgarth
This is an initial commit, containing quick fixes and hacks to allow building the images. All these issues will be re-evaluated and fixed properly in their own commits. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--classes/sota_atom-c3000.bbclass2
-rw-r--r--classes/sota_xeon-d.bbclass2
-rw-r--r--conf/distro/eneanfvaccess.conf2
-rw-r--r--conf/template.atom-c3000/bblayers.conf.sample1
-rw-r--r--conf/template.atom-c3000/local.conf.sample2
-rw-r--r--conf/template.xeon-d/bblayers.conf.sample1
-rw-r--r--conf/template.xeon-d/local.conf.sample2
-rw-r--r--images/enea-nfv-access-common.inc4
-rw-r--r--images/enea-nfv-access-host-common.inc12
-rw-r--r--images/enea-nfv-access.bb1
10 files changed, 19 insertions, 10 deletions
diff --git a/classes/sota_atom-c3000.bbclass b/classes/sota_atom-c3000.bbclass
index dff4294..cb44af4 100644
--- a/classes/sota_atom-c3000.bbclass
+++ b/classes/sota_atom-c3000.bbclass
@@ -7,7 +7,7 @@ WKS_FILE_sota = "efiimage-sota.wks"
7OSTREE_INITRAMFS_FSTYPES ?= "ext4.gz" 7OSTREE_INITRAMFS_FSTYPES ?= "ext4.gz"
8 8
9# Set .otaimg to be used as source for generating hddimg 9# Set .otaimg to be used as source for generating hddimg
10ROOTFS_sota = "${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.otaimg" 10ROOTFS_sota = "${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.ota-ext4"
11 11
12# OSTree initrd needs 'ramdisk_size' and 'rw' parameters in order to boot 12# OSTree initrd needs 'ramdisk_size' and 'rw' parameters in order to boot
13OSTREE_KERNEL_ARGS ?= "rw" 13OSTREE_KERNEL_ARGS ?= "rw"
diff --git a/classes/sota_xeon-d.bbclass b/classes/sota_xeon-d.bbclass
index dff4294..cb44af4 100644
--- a/classes/sota_xeon-d.bbclass
+++ b/classes/sota_xeon-d.bbclass
@@ -7,7 +7,7 @@ WKS_FILE_sota = "efiimage-sota.wks"
7OSTREE_INITRAMFS_FSTYPES ?= "ext4.gz" 7OSTREE_INITRAMFS_FSTYPES ?= "ext4.gz"
8 8
9# Set .otaimg to be used as source for generating hddimg 9# Set .otaimg to be used as source for generating hddimg
10ROOTFS_sota = "${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.otaimg" 10ROOTFS_sota = "${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.ota-ext4"
11 11
12# OSTree initrd needs 'ramdisk_size' and 'rw' parameters in order to boot 12# OSTree initrd needs 'ramdisk_size' and 'rw' parameters in order to boot
13OSTREE_KERNEL_ARGS ?= "rw" 13OSTREE_KERNEL_ARGS ?= "rw"
diff --git a/conf/distro/eneanfvaccess.conf b/conf/distro/eneanfvaccess.conf
index ae26b2d..c31363d 100644
--- a/conf/distro/eneanfvaccess.conf
+++ b/conf/distro/eneanfvaccess.conf
@@ -8,7 +8,7 @@ DISTRO_VERSION = "${DISTRO_VERSION_MAJOR}${DISTRO_VERSION_MINOR}"
8SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}" 8SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
9 9
10INHERIT += "distrooverrides" 10INHERIT += "distrooverrides"
11DISTRO_FEATURES_append = " odm efi-secure-boot" 11DISTRO_FEATURES_append = " odm efi-secure-boot usrmerge"
12DISTRO_FEATURES_OVERRIDES += "odm efi-secure-boot" 12DISTRO_FEATURES_OVERRIDES += "odm efi-secure-boot"
13 13
14PREFERRED_PROVIDER_virtual/java-initial-native = "cacao-initial-native" 14PREFERRED_PROVIDER_virtual/java-initial-native = "cacao-initial-native"
diff --git a/conf/template.atom-c3000/bblayers.conf.sample b/conf/template.atom-c3000/bblayers.conf.sample
index 71c77cc..f5d25ce 100644
--- a/conf/template.atom-c3000/bblayers.conf.sample
+++ b/conf/template.atom-c3000/bblayers.conf.sample
@@ -28,4 +28,5 @@ BBLAYERS ?= " \
28 ##OEROOT##/meta-secure-core/meta-signing-key \ 28 ##OEROOT##/meta-secure-core/meta-signing-key \
29 ##OEROOT##/meta-secure-core/meta-efi-secure-boot \ 29 ##OEROOT##/meta-secure-core/meta-efi-secure-boot \
30 ##OEROOT##/meta-enea-user-keys \ 30 ##OEROOT##/meta-enea-user-keys \
31 ##OEROOT##/meta-python2 \
31 " 32 "
diff --git a/conf/template.atom-c3000/local.conf.sample b/conf/template.atom-c3000/local.conf.sample
index b015f43..374cace 100644
--- a/conf/template.atom-c3000/local.conf.sample
+++ b/conf/template.atom-c3000/local.conf.sample
@@ -273,3 +273,5 @@ USERADD_GID_TABLES = "files/group"
273# Unfortunately, setting the variable below breaks the build, so do not set it 273# Unfortunately, setting the variable below breaks the build, so do not set it
274# for now 274# for now
275# USERADD_ERROR_DYNAMIC = "1" 275# USERADD_ERROR_DYNAMIC = "1"
276
277IMAGE_INSTALL += "dpdk"
diff --git a/conf/template.xeon-d/bblayers.conf.sample b/conf/template.xeon-d/bblayers.conf.sample
index 71c77cc..f5d25ce 100644
--- a/conf/template.xeon-d/bblayers.conf.sample
+++ b/conf/template.xeon-d/bblayers.conf.sample
@@ -28,4 +28,5 @@ BBLAYERS ?= " \
28 ##OEROOT##/meta-secure-core/meta-signing-key \ 28 ##OEROOT##/meta-secure-core/meta-signing-key \
29 ##OEROOT##/meta-secure-core/meta-efi-secure-boot \ 29 ##OEROOT##/meta-secure-core/meta-efi-secure-boot \
30 ##OEROOT##/meta-enea-user-keys \ 30 ##OEROOT##/meta-enea-user-keys \
31 ##OEROOT##/meta-python2 \
31 " 32 "
diff --git a/conf/template.xeon-d/local.conf.sample b/conf/template.xeon-d/local.conf.sample
index 5cfebf5..fd14580 100644
--- a/conf/template.xeon-d/local.conf.sample
+++ b/conf/template.xeon-d/local.conf.sample
@@ -274,3 +274,5 @@ USERADD_GID_TABLES = "files/group"
274# Unfortunately, setting the variable below breaks the build, so do not set it 274# Unfortunately, setting the variable below breaks the build, so do not set it
275# for now 275# for now
276# USERADD_ERROR_DYNAMIC = "1" 276# USERADD_ERROR_DYNAMIC = "1"
277
278IMAGE_INSTALL += "dpdk"
diff --git a/images/enea-nfv-access-common.inc b/images/enea-nfv-access-common.inc
index 5472056..a10e2e2 100644
--- a/images/enea-nfv-access-common.inc
+++ b/images/enea-nfv-access-common.inc
@@ -18,9 +18,9 @@ rootfs_postinstall_dpkg_cleanup () {
18} 18}
19ROOTFS_POSTINSTALL_COMMAND_append += " rootfs_postinstall_dpkg_cleanup;" 19ROOTFS_POSTINSTALL_COMMAND_append += " rootfs_postinstall_dpkg_cleanup;"
20 20
21IMAGE_FSTYPES = "ext4 ext4.gz tar.gz" 21IMAGE_FSTYPES += "ext4 ext4.gz tar.gz"
22 22
23# Add ostree specific image types if sota support is set 23# Add ostree specific image types if sota support is set
24IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'otaimg wic', ' ', d)}" 24IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ota-ext4 wic', ' ', d)}"
25SOTA_CLIENT = "" 25SOTA_CLIENT = ""
26SOTA_CLIENT_PROV = "" 26SOTA_CLIENT_PROV = ""
diff --git a/images/enea-nfv-access-host-common.inc b/images/enea-nfv-access-host-common.inc
index 1cde827..c0cd896 100644
--- a/images/enea-nfv-access-host-common.inc
+++ b/images/enea-nfv-access-host-common.inc
@@ -3,8 +3,6 @@ REQUIRE_FILES = " \
3 classes/override_grub-efi.inc \ 3 classes/override_grub-efi.inc \
4 " 4 "
5REQUIRE_FILES_append_df-efi-secure-boot = " \ 5REQUIRE_FILES_append_df-efi-secure-boot = " \
6 classes/override_image_types_ostree.inc \
7 classes/override_image_types_ota.inc \
8 classes/override_grub-efi_secureboot.inc \ 6 classes/override_grub-efi_secureboot.inc \
9 images/secure-boot.inc \ 7 images/secure-boot.inc \
10 " 8 "
@@ -16,6 +14,12 @@ IMAGE_INSTALL += " \
16 packagegroup-enea-virtualization-4gusb-modems \ 14 packagegroup-enea-virtualization-4gusb-modems \
17 " 15 "
18 16
17#This should not be needed, it's a hack. Without it it complains hddimg is not recognize
18#See image.bbclass +13.
19#inherit image-live
20
21IMAGE_FSTYPES += "hddimg"
22
19# Set labels for GRUB and SYSLINUX 23# Set labels for GRUB and SYSLINUX
20LABELS_LIVE = "installer live-boot" 24LABELS_LIVE = "installer live-boot"
21 25
@@ -30,13 +34,13 @@ AUTO_SYSLINUXMENU_x86-64 = "0"
30 34
31# grub-efi-native is needed in recipe-sysroot-native to generate the initial 35# grub-efi-native is needed in recipe-sysroot-native to generate the initial
32# configuration file for grub 36# configuration file for grub
33DEPENDS_append += " grub-efi-native" 37DEPENDS_append += " grub-efi-native qemuwrapper-cross"
34 38
35# If building with sota enabled, build the otaimg before the hddimg, because 39# If building with sota enabled, build the otaimg before the hddimg, because
36# the hddimg needs it as a base image 40# the hddimg needs it as a base image
37python __anonymous() { 41python __anonymous() {
38 if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d): 42 if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d):
39 d.appendVarFlag("do_bootimg", "depends", " %s:do_image_otaimg" % d.getVar("IMAGE_BASENAME", True)) 43 d.appendVarFlag("do_bootimg", "depends", " %s:do_image_ota_ext4" % d.getVar("IMAGE_BASENAME", True))
40} 44}
41 45
42# Append OSTree specific parameters to the kernel command line before creating the live image 46# Append OSTree specific parameters to the kernel command line before creating the live image
diff --git a/images/enea-nfv-access.bb b/images/enea-nfv-access.bb
index 9311992..08239ae 100644
--- a/images/enea-nfv-access.bb
+++ b/images/enea-nfv-access.bb
@@ -3,5 +3,4 @@ DESCRIPTION = "Image for the host side of the Enea NFV Access Platform with ODM
3require images/enea-nfv-access-host-common.inc 3require images/enea-nfv-access-host-common.inc
4 4
5IMAGE_INSTALL += " \ 5IMAGE_INSTALL += " \
6 element-vcpe \
7 " 6 "