summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-04-18 15:46:58 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-04-18 15:46:58 +0200
commitdf183762f7f4009488f899ce57c4aafabf5bb1f1 (patch)
treeaa6d1929a132acbd44b6042fbdc5cf43cc1e9e30
downloadmeta-el-networking-df183762f7f4009488f899ce57c4aafabf5bb1f1.tar.gz
Initialize layer
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--COPYING.MIT17
-rw-r--r--README66
-rw-r--r--conf/layer.conf14
3 files changed, 97 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..89de354
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/README b/README
new file mode 100644
index 0000000..05b77d3
--- /dev/null
+++ b/README
@@ -0,0 +1,66 @@
1meta-el-networking
2===================================================================
3
4This layer contains distro customizations specific to the Enea Linux
5Networking profile releases.
6
7Dependencies
8============
9
10This layer depends on:
11
12 URI: git://git.yoctoproject.org/poky
13 branch: master
14
15 URI: git://git.enea.com/linux/meta-el-common
16 branch: master
17
18 URI: git://git.enea.com/linux/meta-enea-networking
19 branch: master
20
21
22
23Source code
24===========
25
26git://git.enea.com/linux/meta-el-networking.git
27
28
29Patches
30=======
31
32Please submit any patches against the el-networking layer to the
33linux-maintainers mailing list: linux-maintainers@enea.com
34
35Maintainers: Enea Linux Team <linux-maintainers@enea.com>
36
37
38Table
39=================
40
41 I. Adding the el-networking layer to your build
42 II. Misc
43
44
45I. Adding the el-networking layer to your build
46=================================================
47
48In order to use this layer, you need to make the build system aware of
49it.
50
51Assuming the el-networking layer exists at the top-level of your
52yocto build tree, you can add it to the build system by adding the
53location of the el-networking layer to bblayers.conf, along with any
54other layers needed. e.g.:
55
56
57 BBLAYERS ?= " \
58 /path/to/yocto/meta \
59 /path/to/yocto/meta-poky \
60 /path/to/yocto/meta-el-common \
61 /path/to/yocto/meta-enea-networking \
62 /path/to/yocto/meta-el-networking \
63 "
64
65II. Misc
66========
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..f7f7733
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,14 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/images/* \
7 ${LAYERDIR}/packagegroups/* \
8 ${LAYERDIR}/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS += "el-networking"
11BBFILE_PATTERN_el-networking = "^${LAYERDIR}/"
12BBFILE_PRIORITY_el-networking = "7"
13LAYERDEPENDS_el-networking = "el-common enea-networking"
14