summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch35
-rw-r--r--recipes-devtools/automake/automake_1.14.1.bbappend5
-rw-r--r--recipes-devtools/elfutils/elfutils/add-ptest.patch23
-rw-r--r--recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch20
-rw-r--r--recipes-devtools/elfutils/elfutils/run-ptest3
-rw-r--r--recipes-devtools/elfutils/elfutils_0.148.bbappend19
-rw-r--r--recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch26
-rw-r--r--recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch30
-rw-r--r--recipes-devtools/gdb/gdb/change-scripts-support-from-ksh-to-bash.patch14
-rw-r--r--recipes-devtools/gdb/gdb/gdb-ptest-attach.patch30
-rwxr-xr-xrecipes-devtools/gdb/gdb/run-ptest2
-rw-r--r--recipes-devtools/gdb/gdb/runtest-flags.patch30
-rw-r--r--recipes-devtools/gdb/gdb_7.7.1.bbappend40
-rw-r--r--recipes-devtools/python/python-smartpm/smart-already-installed-message.patch54
-rw-r--r--recipes-devtools/python/python-smartpm_1.4.1.bbappend5
-rw-r--r--recipes-devtools/tclap/tclap_1.2.1.bbappend1
16 files changed, 337 insertions, 0 deletions
diff --git a/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch b/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
new file mode 100644
index 0000000..fae10b3
--- /dev/null
+++ b/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
@@ -0,0 +1,35 @@
1Set relative to top_builddir path in Makefile to access test-driver
2
3Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
4Upstream-Status: Pending
5
6--- a/bin/automake.in
7+++ b/bin/automake.in
8@@ -272,6 +272,9 @@
9 # $AM_CONFIG_AUX_DIR is prefixed with $(top_srcdir), so it can be used
10 # in Makefiles.
11 my $am_config_aux_dir = '';
12+# Directory used at runtime like running test-driver that should not
13+# depend on $(top_srcdir)
14+my $am_config_rt_aux_dir = '';
15
16 # Directory to search for AC_LIBSOURCE files, as set by AC_CONFIG_LIBOBJ_DIR
17 # in configure.ac.
18@@ -4700,7 +4703,7 @@
19 {
20 require_conf_file ("parallel-tests", FOREIGN, 'test-driver');
21 define_variable ("${pfx}LOG_DRIVER",
22- "\$(SHELL) $am_config_aux_dir/test-driver",
23+ "\$(SHELL) $am_config_rt_aux_dir/test-driver",
24 INTERNAL);
25 }
26 my $driver = '$(' . $pfx . 'LOG_DRIVER)';
27@@ -7284,6 +7287,10 @@
28 $am_config_aux_dir =
29 '$(top_srcdir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
30 $am_config_aux_dir =~ s,/*$,,;
31+
32+ $am_config_rt_aux_dir =
33+ '$(top_builddir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
34+ $am_config_rt_aux_dir =~ s,/*$,,;
35 }
diff --git a/recipes-devtools/automake/automake_1.14.1.bbappend b/recipes-devtools/automake/automake_1.14.1.bbappend
new file mode 100644
index 0000000..c3f22b8
--- /dev/null
+++ b/recipes-devtools/automake/automake_1.14.1.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " \
4 file://new_rt_path_for_test-driver.patch \
5 "
diff --git a/recipes-devtools/elfutils/elfutils/add-ptest.patch b/recipes-devtools/elfutils/elfutils/add-ptest.patch
new file mode 100644
index 0000000..88f808d
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/add-ptest.patch
@@ -0,0 +1,23 @@
1Add 'install-ptest' rule.
2
3Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com>
4Upstream-status: Pending
5---
6diff -uNr a/tests/Makefile.am b/tests/Makefile.am
7--- a/tests/Makefile.am 2013-08-19 14:05:23.256292155 +0200
8+++ b/tests/Makefile.am 2013-08-19 15:49:16.084543591 +0200
9@@ -240,3 +240,14 @@
10 coverage:
11 -$(srcdir)/coverage.sh
12 endif
13+
14+install-ptest:
15+ @$(MKDIR_P) $(DESTDIR)/tests
16+ @$(MKDIR_P) $(DESTDIR)/src
17+ @install $(builddir)/*$(EXEEXT) $(DESTDIR)/tests
18+ @install $(srcdir)/*.sh $(DESTDIR)/tests
19+ @install $(builddir)/../src/*$(EXEEXT) $(DESTDIR)/src
20+ @cp $(builddir)/../Makefile $(DESTDIR)
21+ @sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/tests/Makefile
22+ @sed -i -e 's|$(srcdir)|.|' $(DESTDIR)/tests/Makefile
23+
diff --git a/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch b/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch
new file mode 100644
index 0000000..ed6b6ef
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch
@@ -0,0 +1,20 @@
1ptest needs buildtest-TESTS and runtest-TESTS targets.
2serial-tests is required to generate those targets.
3
4Signed-off-by: Alexandra Safta <alexandra.safta@enea.com>
5Signed-off-by: Tudor Florea <tudor.florea@enea.com>
6Upstream-Status: Inappropriate
7
8diff -ruN a/configure.ac b/configure.ac
9
10--- a/configure.ac 2014-05-26 18:55:11.843190780 +0200
11+++ b/configure.ac 2014-05-26 18:56:01.725097919 +0200
12@@ -25,7 +25,7 @@
13 AC_PREREQ(2.63) dnl Minimum Autoconf version required.
14
15 dnl We use GNU make extensions; automake 1.10 defaults to -Wportability.
16-AM_INIT_AUTOMAKE([gnits 1.8 -Wno-portability dist-bzip2 no-dist-gzip])
17+AM_INIT_AUTOMAKE([gnits 1.8 -Wno-portability dist-bzip2 no-dist-gzip serial-tests])
18 AM_MAINTAINER_MODE
19
20 dnl Unique ID for this build.
diff --git a/recipes-devtools/elfutils/elfutils/run-ptest b/recipes-devtools/elfutils/elfutils/run-ptest
new file mode 100644
index 0000000..51ea6df
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3make -C tests -k runtest-TESTS
diff --git a/recipes-devtools/elfutils/elfutils_0.148.bbappend b/recipes-devtools/elfutils/elfutils_0.148.bbappend
new file mode 100644
index 0000000..704829a
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils_0.148.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "\
4 file://add-ptest.patch \
5 file://run-ptest \
6 file://avoid_parallel_tests.patch \
7"
8
9inherit ptest
10
11do_compile_ptest() {
12 oe_runmake -C tests buildtest-TESTS
13}
14
15do_install_ptest() {
16 oe_runmake -C tests install-ptest DESTDIR=${D}${PTEST_PATH}
17}
18
19RDEPENDS_${PN}-ptest += " bash"
diff --git a/recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch b/recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch
new file mode 100644
index 0000000..1c41562
--- /dev/null
+++ b/recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch
@@ -0,0 +1,26 @@
1Description: Add delay for stable running
2
3Author: jack zhang <jack.zhang@enea.com>
4Date: Mon, 12 Nov 2012 04:10:20 +0100
5
6Upstream-Status: Pending
7
8Signed-off-by: jack zhang <jack.zhang@enea.com>
9Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com>
10---
11 gdb/testsuite/dg-extract-results.sh | 1 +
12 1 files changed, 1 insertions(+), 0 deletions(-)
13
14diff --git a/gdb/testsuite/dg-extract-results.sh b/gdb/testsuite/dg-extract-results.sh
15--- a/gdb/testsuite/dg-extract-results.sh
16+++ b/gdb/testsuite/dg-extract-results.sh
17@@ -322,6 +322,7 @@ END {
18 n=1
19 while (n < expfileno) {
20 if (expfileseen[expfiles[n]]) {
21+ sleep 1
22 print "Running "expfiles[n]" ..."
23 if (filewritten["${TMP}/list"n]) {
24 if (expfileseen[expfiles[n]] == 1)
25--
261.7.5.4
diff --git a/recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch b/recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch
new file mode 100644
index 0000000..7f25a35
--- /dev/null
+++ b/recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch
@@ -0,0 +1,30 @@
1Description: function name is used by mistake
2
3Author: jack zhang <jack.zhang@enea.com>
4Date: Tue, 13 Nov 2012 09:56:54 +0100
5
6Upstream-Status: Pending
7
8Signed-off-by: jack zhang <jack.zhang@enea.com>
9Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com>
10---
11 gdb/testsuite/gdb.base/skip.exp | 4 ++--
12 1 files changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/gdb/testsuite/gdb.base/skip.exp b/gdb/testsuite/gdb.base/skip.exp
15--- a/gdb/testsuite/gdb.base/skip.exp
16+++ b/gdb/testsuite/gdb.base/skip.exp
17@@ -113,9 +113,9 @@ gdb_test "info skip 3" ".*\\n3\\s+file\\s+n.*" \
18 "info skip shows entry as disabled"
19
20 if ![runto_main] { fail "skip tests suppressed" }
21-gdb_test "step" "bar \\(\\) at.*" "step after disabling 3 (1)"
22+gdb_test "step" "foo \\(\\) at.*" "step after disabling 3 (1)"
23 gdb_test "step" ".*" "step after disabling 3 (2)"; # Return from foo()
24-gdb_test "step" "foo \\(\\) at.*" "step after disabling 3 (3)"
25+gdb_test "step" "bar \\(\\) at.*" "step after disabling 3 (3)"
26 gdb_test "step" ".*" "step after disabling 3 (4)"; # Return from bar()
27 gdb_test "step" "main \\(\\) at.*" "step after disabling 3 (5)"
28
29--
301.7.5.4
diff --git a/recipes-devtools/gdb/gdb/change-scripts-support-from-ksh-to-bash.patch b/recipes-devtools/gdb/gdb/change-scripts-support-from-ksh-to-bash.patch
new file mode 100644
index 0000000..d98affc
--- /dev/null
+++ b/recipes-devtools/gdb/gdb/change-scripts-support-from-ksh-to-bash.patch
@@ -0,0 +1,14 @@
1Avoid ksh dependency
2
3Upstream-Status: Pending
4
5Signed-off-by: Paul Vaduva <paul.vaduva@enea.com>
6diff -Naur a/gdb/testsuite/gdb.hp/tools/odump b/gdb/testsuite/gdb.hp/tools/odump
7--- a/gdb/testsuite/gdb.hp/tools/odump 2015-05-25 10:13:31.956107840 +0200
8+++ b/gdb/testsuite/gdb.hp/tools/odump 2015-05-25 10:14:04.690707176 +0200
9@@ -1,4 +1,4 @@
10-#!/bin/ksh
11+#!/bin/bash
12
13 # First source /app/appserver
14 . /app/appserver
diff --git a/recipes-devtools/gdb/gdb/gdb-ptest-attach.patch b/recipes-devtools/gdb/gdb/gdb-ptest-attach.patch
new file mode 100644
index 0000000..b95ac2c
--- /dev/null
+++ b/recipes-devtools/gdb/gdb/gdb-ptest-attach.patch
@@ -0,0 +1,30 @@
1From f442dc426b0346e1e413a7c3ae5b07725837135c Mon Sep 17 00:00:00 2001
2From: "Rick.Yang" <rick.yang@enea.com>
3Date: Sun, 11 Nov 2012 10:05:50 +0100
4Subject: [PATCH] Fix the failed test case.
5
6Description: Fixed failing test case
7 In fact, the test case is passing, but the output does not completely
8 match the expected pattern in some special case. Modified the pattern
9 to resolve it.
10
11Signed-off-by: Rick.Yang <rick.yang@enea.com>
12Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com>
13---
14 gdb/testsuite/gdb.base/attach.exp | 2 +-
15 1 files changed, 1 insertions(+), 1 deletions(-)
16
17diff --git a/gdb/testsuite/gdb.base/attach.exp b/gdb/testsuite/gdb.base/attach.exp
18--- a/gdb/testsuite/gdb.base/attach.exp
19+++ b/gdb/testsuite/gdb.base/attach.exp
20@@ -285,7 +285,7 @@ proc do_attach_tests {} {
21 gdb_test "dir ${objdir}/${subdir}" "Source directories searched: .*" \
22 "set source path"
23
24- gdb_test "cd /tmp" "Working directory /tmp." \
25+ gdb_test "cd /tmp" "Working directory /tmp.*" \
26 "cd away from process working directory"
27
28 # Explicitly flush out any knowledge of the previous attachment.
29--
301.7.5.4
diff --git a/recipes-devtools/gdb/gdb/run-ptest b/recipes-devtools/gdb/gdb/run-ptest
new file mode 100755
index 0000000..e8587e8
--- /dev/null
+++ b/recipes-devtools/gdb/gdb/run-ptest
@@ -0,0 +1,2 @@
1#!/bin/sh
2make -C testsuite check-single | sed -e 's/XFAIL/PASS/' -e 's/UNRESOLVED/SKIP/' -e 's/UNTESTED/SKIP/' -e 's/UNSUPPORTED/SKIP/'
diff --git a/recipes-devtools/gdb/gdb/runtest-flags.patch b/recipes-devtools/gdb/gdb/runtest-flags.patch
new file mode 100644
index 0000000..054abc3
--- /dev/null
+++ b/recipes-devtools/gdb/gdb/runtest-flags.patch
@@ -0,0 +1,30 @@
1Description: add -a to runtest
2 Pass "-a" to runtest so that everything is printed to output
3 (e.g. unsupported test cases)
4
5Author: "Gordon.Sun" <gordon.sun@enea.com>
6Date: Wed, 28 Nov 2012 03:39:58 +0100
7
8Upstream-Status: Inappropriate (other)
9
10Signed-off-by: Gordon.Sun <gordon.sun@enea.com>
11Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com>
12---
13 gdb/testsuite/Makefile.in | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-)
15
16diff --git a/gdb/testsuite/Makefile.in b/gdb/testsuite/Makefile.in
17index fab124e..f5cddb2 100644
18--- a/gdb/testsuite/Makefile.in
19+++ b/gdb/testsuite/Makefile.in
20@@ -46,7 +46,7 @@ EXPECT = `if [ -f $${rootme}/../../expect/expect ] ; then \
21
22 RUNTEST = $(RUNTEST_FOR_TARGET)
23
24-RUNTESTFLAGS =
25+RUNTESTFLAGS = -a
26
27 FORCE_PARALLEL =
28
29--
301.7.5.4
diff --git a/recipes-devtools/gdb/gdb_7.7.1.bbappend b/recipes-devtools/gdb/gdb_7.7.1.bbappend
new file mode 100644
index 0000000..2da31a0
--- /dev/null
+++ b/recipes-devtools/gdb/gdb_7.7.1.bbappend
@@ -0,0 +1,40 @@
1inherit ptest
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://run-ptest \
6 file://runtest-flags.patch \
7 file://0001-add-delay-before-run-exp-file.patch \
8 file://0002-function-name-is-used-by-mistake.patch \
9 file://gdb-ptest-attach.patch \
10 file://change-scripts-support-from-ksh-to-bash.patch \
11 "
12
13
14
15DEPENDS_${PN}-ptest += "expect dejagnu tcl"
16RDEPENDS_${PN}-ptest += "glibc-charmap-ibm1047 \
17 glibc-gconv-ibm1047 \
18 glibc-charmap-ebcdic-us \
19 glibc-gconv-ebcdic-us \
20 glibc-gconv-utf-32 \
21 glibc-gconv-utf-16 \
22 prelink \
23 expect \
24 dejagnu \
25 make \
26 bash \
27 "
28do_configure_ptest () {
29 cd ${S}/gdb/testsuite/
30 ./configure --host=${HOST_SYS} --build=${BUILD_SYS}
31 make site.exp
32}
33
34do_install_ptest () {
35 cp -pr ${S}/gdb/testsuite/ ${D}${PTEST_PATH}
36 cp -pr ${S}/gdb/features/ ${D}${PTEST_PATH}
37 install -p ${S}/config.sub ${D}${PTEST_PATH}/testsuite/
38 install -p ${S}/config.guess ${D}${PTEST_PATH}/testsuite/
39 install -p ${S}/install-sh ${D}${PTEST_PATH}/testsuite/
40}
diff --git a/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch b/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
new file mode 100644
index 0000000..e264de8
--- /dev/null
+++ b/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
@@ -0,0 +1,54 @@
1
2From a74a9a9eb9d75964a0e978950e8b191d7a18d763 Mon Sep 17 00:00:00 2001
3From: Paul Eggleton <paul.eggleton@linux.intel.com>
4Date: Fri, 5 Jun 2015 17:07:16 +0100
5Subject: [PATCH] smart: change "is already installed" message from warning to
6 info
7
8This doesn't need to be a warning.
9
10Upstream-Status: Pending
11
12Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
13---
14 smart/commands/install.py | 4 ++--
15 smart/interfaces/text/interactive.py | 2 +-
16 2 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/smart/commands/install.py b/smart/commands/install.py
19index 6ef9682..80d456b 100644
20--- a/smart/commands/install.py
21+++ b/smart/commands/install.py
22@@ -152,7 +152,7 @@ def main(ctrl, opts):
23 for obj in results:
24 for pkg in obj.packages:
25 if pkg.installed:
26- iface.warning(_("%s (for %s) is already installed")
27+ iface.info(_("%s (for %s) is already installed")
28 % (pkg, arg))
29 installed = True
30 break
31@@ -184,7 +184,7 @@ def main(ctrl, opts):
32 for name in names:
33 pkg = names[name][0]
34 if pkg.installed:
35- iface.warning(_("%s is already installed") % pkg)
36+ iface.info(_("%s is already installed") % pkg)
37 else:
38 trans.enqueue(pkg, INSTALL)
39
40diff --git a/smart/interfaces/text/interactive.py b/smart/interfaces/text/interactive.py
41index 9865584..190867b 100644
42--- a/smart/interfaces/text/interactive.py
43+++ b/smart/interfaces/text/interactive.py
44@@ -278,7 +278,7 @@ class Interpreter(Cmd):
45 for name in names:
46 pkg = names[name][0]
47 if pkg.installed:
48- iface.warning(_("%s is already installed") % pkg)
49+ iface.info(_("%s is already installed") % pkg)
50 else:
51 found = True
52 transaction.enqueue(pkg, INSTALL)
53--
542.1.0
diff --git a/recipes-devtools/python/python-smartpm_1.4.1.bbappend b/recipes-devtools/python/python-smartpm_1.4.1.bbappend
new file mode 100644
index 0000000..1148437
--- /dev/null
+++ b/recipes-devtools/python/python-smartpm_1.4.1.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "\
4 file://smart-already-installed-message.patch \
5"
diff --git a/recipes-devtools/tclap/tclap_1.2.1.bbappend b/recipes-devtools/tclap/tclap_1.2.1.bbappend
new file mode 100644
index 0000000..afe3e9c
--- /dev/null
+++ b/recipes-devtools/tclap/tclap_1.2.1.bbappend
@@ -0,0 +1 @@
ALLOW_EMPTY_${PN} = "1"