summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gdb/gdb_7.7.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/gdb/gdb_7.7.1.bbappend')
-rw-r--r--recipes-devtools/gdb/gdb_7.7.1.bbappend40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/gdb/gdb_7.7.1.bbappend b/recipes-devtools/gdb/gdb_7.7.1.bbappend
new file mode 100644
index 0000000..2da31a0
--- /dev/null
+++ b/recipes-devtools/gdb/gdb_7.7.1.bbappend
@@ -0,0 +1,40 @@
1inherit ptest
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://run-ptest \
6 file://runtest-flags.patch \
7 file://0001-add-delay-before-run-exp-file.patch \
8 file://0002-function-name-is-used-by-mistake.patch \
9 file://gdb-ptest-attach.patch \
10 file://change-scripts-support-from-ksh-to-bash.patch \
11 "
12
13
14
15DEPENDS_${PN}-ptest += "expect dejagnu tcl"
16RDEPENDS_${PN}-ptest += "glibc-charmap-ibm1047 \
17 glibc-gconv-ibm1047 \
18 glibc-charmap-ebcdic-us \
19 glibc-gconv-ebcdic-us \
20 glibc-gconv-utf-32 \
21 glibc-gconv-utf-16 \
22 prelink \
23 expect \
24 dejagnu \
25 make \
26 bash \
27 "
28do_configure_ptest () {
29 cd ${S}/gdb/testsuite/
30 ./configure --host=${HOST_SYS} --build=${BUILD_SYS}
31 make site.exp
32}
33
34do_install_ptest () {
35 cp -pr ${S}/gdb/testsuite/ ${D}${PTEST_PATH}
36 cp -pr ${S}/gdb/features/ ${D}${PTEST_PATH}
37 install -p ${S}/config.sub ${D}${PTEST_PATH}/testsuite/
38 install -p ${S}/config.guess ${D}${PTEST_PATH}/testsuite/
39 install -p ${S}/install-sh ${D}${PTEST_PATH}/testsuite/
40}