summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gdb/gdb_7.10.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/gdb/gdb_7.10.1.bbappend')
-rw-r--r--recipes-devtools/gdb/gdb_7.10.1.bbappend39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-devtools/gdb/gdb_7.10.1.bbappend b/recipes-devtools/gdb/gdb_7.10.1.bbappend
new file mode 100644
index 0000000..89404b1
--- /dev/null
+++ b/recipes-devtools/gdb/gdb_7.10.1.bbappend
@@ -0,0 +1,39 @@
1inherit ptest
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://run-ptest \
6 file://runtest-flags.patch \
7 file://0001-add-delay-before-run-exp-file.patch \
8 file://0002-function-name-is-used-by-mistake.patch \
9 file://gdb-ptest-attach.patch \
10 "
11
12
13
14DEPENDS_${PN}-ptest += "expect dejagnu tcl"
15RDEPENDS_${PN}-ptest += "glibc-charmap-ibm1047 \
16 glibc-gconv-ibm1047 \
17 glibc-charmap-ebcdic-us \
18 glibc-gconv-ebcdic-us \
19 glibc-gconv-utf-32 \
20 glibc-gconv-utf-16 \
21 prelink \
22 expect \
23 dejagnu \
24 make \
25 bash \
26 "
27do_configure_ptest () {
28 cd ${S}/gdb/testsuite/
29 ./configure --host=${HOST_SYS} --build=${BUILD_SYS}
30 make site.exp
31}
32
33do_install_ptest () {
34 cp -pr ${S}/gdb/testsuite/ ${D}${PTEST_PATH}
35 cp -pr ${S}/gdb/features/ ${D}${PTEST_PATH}
36 install -p ${S}/config.sub ${D}${PTEST_PATH}/testsuite/
37 install -p ${S}/config.guess ${D}${PTEST_PATH}/testsuite/
38 install -p ${S}/install-sh ${D}${PTEST_PATH}/testsuite/
39}