summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2015-10-28 13:30:10 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2015-10-28 13:30:10 +0100
commit38929ed6a4630d2b8f3efa00616800b4012ea0d7 (patch)
tree22bd8dca4994cd3d73f7f959f57f0bc7137d04cf /recipes-extended
downloadmeta-el-common-38929ed6a4630d2b8f3efa00616800b4012ea0d7.tar.gz
Initial commit
result of splitting up meta-enea Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libuio/libuio/run-ptest3
-rw-r--r--recipes-extended/libuio/libuio_git.bb31
-rw-r--r--recipes-extended/ltp/ltp_20140422.bbappend3
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes-extended/libuio/libuio/run-ptest b/recipes-extended/libuio/libuio/run-ptest
new file mode 100644
index 0000000..46c80b5
--- /dev/null
+++ b/recipes-extended/libuio/libuio/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2echo "SKIP: no upstream test"
3
diff --git a/recipes-extended/libuio/libuio_git.bb b/recipes-extended/libuio/libuio_git.bb
new file mode 100644
index 0000000..216c678
--- /dev/null
+++ b/recipes-extended/libuio/libuio_git.bb
@@ -0,0 +1,31 @@
1SUMMARY = "libUIO"
2DESCRIPTION = "Provide a generic framework for handling devices in userspace."
3HOMEPAGE = "https://www.osadl.org/UIO.uio.0.html"
4SECTION = "libs"
5LICENSE = "GPLv2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SRCREV = "cc233857ba1613801e7218d07127d19608a99702"
10PR = "r0"
11PV = "1.0+git${SRCPV}"
12
13SRC_URI = "git://git.linutronix.de/projects/libUIO;protocol=git \
14 file://run-ptest"
15
16DEPENDS = "virtual/libc"
17
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22do_configure_prepend () {
23 touch ${S}/ChangeLog
24}
25
26do_install_append () {
27 if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
28 mkdir -p ${D}${PTEST_PATH}
29 install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
30 fi
31}
diff --git a/recipes-extended/ltp/ltp_20140422.bbappend b/recipes-extended/ltp/ltp_20140422.bbappend
new file mode 100644
index 0000000..59a4341
--- /dev/null
+++ b/recipes-extended/ltp/ltp_20140422.bbappend
@@ -0,0 +1,3 @@
1do_compile_prepend () {
2 ( make -C ${B}/testcases/open_posix_testsuite generate-makefiles conformance-all tools-all functional-all stress-all )
3}