diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2015-10-28 13:30:10 +0100 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2015-10-28 13:30:10 +0100 |
commit | 38929ed6a4630d2b8f3efa00616800b4012ea0d7 (patch) | |
tree | 22bd8dca4994cd3d73f7f959f57f0bc7137d04cf /recipes-enea/list2mask | |
download | meta-el-common-38929ed6a4630d2b8f3efa00616800b4012ea0d7.tar.gz |
Initial commit
result of splitting up meta-enea
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-enea/list2mask')
-rw-r--r-- | recipes-enea/list2mask/list2mask/run-ptest | 15 | ||||
-rw-r--r-- | recipes-enea/list2mask/list2mask_1.0.bb | 25 |
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-enea/list2mask/list2mask/run-ptest b/recipes-enea/list2mask/list2mask/run-ptest new file mode 100644 index 0000000..9eb6c2f --- /dev/null +++ b/recipes-enea/list2mask/list2mask/run-ptest | |||
@@ -0,0 +1,15 @@ | |||
1 | #!/bin/sh -eu | ||
2 | |||
3 | mask=$(list2mask --cpus 2-3,5,7-8) | ||
4 | |||
5 | if [ $? -ne 0 ]; then | ||
6 | echo "FAIL: list2mask failed to execute" | ||
7 | exit | ||
8 | fi | ||
9 | |||
10 | if [ "$mask" != "1ac" ]; then | ||
11 | echo "FAIL: list2mask returns mask '$mask', expected '1ac'" | ||
12 | exit | ||
13 | fi | ||
14 | |||
15 | echo "PASS: list2mask" | ||
diff --git a/recipes-enea/list2mask/list2mask_1.0.bb b/recipes-enea/list2mask/list2mask_1.0.bb new file mode 100644 index 0000000..d72bcda --- /dev/null +++ b/recipes-enea/list2mask/list2mask_1.0.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Translate CPU list to a CPU mask" | ||
2 | DESCRIPTION = "Translate CPU list given on command line to a hexadecimal CPU mask. Can use kernel boot parameters isolcpus or nohz_full as input as well as a list given on command line." | ||
3 | SECTION = "utils" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4" | ||
6 | |||
7 | PR = "r1" | ||
8 | |||
9 | RDEPENDS_${PN} = "bash" | ||
10 | |||
11 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | SRCREV = "db6eff03d80c04803fb146939c504b500e16fe2f" | ||
16 | |||
17 | inherit ptest | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | FILES_${PN} += "/bin/*" | ||
22 | |||
23 | do_install() { | ||
24 | install -D ${S}/install/bin/${PN} ${D}/usr/bin/${PN} | ||
25 | } | ||