summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-11-20 14:10:45 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2015-11-24 11:08:51 +0100
commit9ea9109bb950be420fe67bb15cadea59c6e544ac (patch)
treefa0e0b2946e710956d03de45e920b430369b8601 /recipes-devtools
parentb9ac3c262f7ffd77106b36f71b1033ae093706fa (diff)
downloadmeta-el-common-9ea9109bb950be420fe67bb15cadea59c6e544ac.tar.gz
python-smartpm: change "already installed" warnings into info messages
It's possible to trigger "already installed" messages during normal usage if you explicitly install something in the image through IMAGE_INSTALL that has a dependency on some -dev packages and also have dev-pkgs in IMAGE_FEATURES. Since we now check the do_rootfs log for warnings, these are reported as warnings at the build system level. This situation should not trigger warnings, nor is it really cause for concern under any other circumstance if the user asks smart to install something that's already installed, so make it an info message rather than a warning. Fixes [YOCTO #7840]. This patch was ported from poky/master Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-smartpm/smart-already-installed-message.patch54
-rw-r--r--recipes-devtools/python/python-smartpm_1.4.1.bbappend5
2 files changed, 59 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch b/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
new file mode 100644
index 0000000..e264de8
--- /dev/null
+++ b/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
@@ -0,0 +1,54 @@
1
2From a74a9a9eb9d75964a0e978950e8b191d7a18d763 Mon Sep 17 00:00:00 2001
3From: Paul Eggleton <paul.eggleton@linux.intel.com>
4Date: Fri, 5 Jun 2015 17:07:16 +0100
5Subject: [PATCH] smart: change "is already installed" message from warning to
6 info
7
8This doesn't need to be a warning.
9
10Upstream-Status: Pending
11
12Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
13---
14 smart/commands/install.py | 4 ++--
15 smart/interfaces/text/interactive.py | 2 +-
16 2 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/smart/commands/install.py b/smart/commands/install.py
19index 6ef9682..80d456b 100644
20--- a/smart/commands/install.py
21+++ b/smart/commands/install.py
22@@ -152,7 +152,7 @@ def main(ctrl, opts):
23 for obj in results:
24 for pkg in obj.packages:
25 if pkg.installed:
26- iface.warning(_("%s (for %s) is already installed")
27+ iface.info(_("%s (for %s) is already installed")
28 % (pkg, arg))
29 installed = True
30 break
31@@ -184,7 +184,7 @@ def main(ctrl, opts):
32 for name in names:
33 pkg = names[name][0]
34 if pkg.installed:
35- iface.warning(_("%s is already installed") % pkg)
36+ iface.info(_("%s is already installed") % pkg)
37 else:
38 trans.enqueue(pkg, INSTALL)
39
40diff --git a/smart/interfaces/text/interactive.py b/smart/interfaces/text/interactive.py
41index 9865584..190867b 100644
42--- a/smart/interfaces/text/interactive.py
43+++ b/smart/interfaces/text/interactive.py
44@@ -278,7 +278,7 @@ class Interpreter(Cmd):
45 for name in names:
46 pkg = names[name][0]
47 if pkg.installed:
48- iface.warning(_("%s is already installed") % pkg)
49+ iface.info(_("%s is already installed") % pkg)
50 else:
51 found = True
52 transaction.enqueue(pkg, INSTALL)
53--
542.1.0
diff --git a/recipes-devtools/python/python-smartpm_1.4.1.bbappend b/recipes-devtools/python/python-smartpm_1.4.1.bbappend
new file mode 100644
index 0000000..1148437
--- /dev/null
+++ b/recipes-devtools/python/python-smartpm_1.4.1.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "\
4 file://smart-already-installed-message.patch \
5"