summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-12-10 22:42:07 +0100
committerAdrian Calianu <adrian.calianu@enea.com>2015-12-14 13:37:40 +0100
commit406ec45b2045b63a73719b1203f3418bace0d122 (patch)
tree5358c5b9fbefcacf7f237903db21e043c79e72da /recipes-devtools
parent476ddf6e0796c8e554fba534b7c7895580d6a53c (diff)
downloadmeta-el-common-406ec45b2045b63a73719b1203f3418bace0d122.tar.gz
ptest: set relative path for test-driver
Starting with dizzy(poky v1.7) parallel testing was activated and test-driver is the log driver for this mechanism. But generated Makefile is using an absolute path when calls the test-driver which is a wrong path at run-time. Signed-off-by: Adrian Calianu <adrian.calianu@enea.com> Signed-off-by: George Nita <george.nita@enea.com> Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch35
-rw-r--r--recipes-devtools/automake/automake_1.14.1.bbappend5
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch b/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
new file mode 100644
index 0000000..fae10b3
--- /dev/null
+++ b/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
@@ -0,0 +1,35 @@
1Set relative to top_builddir path in Makefile to access test-driver
2
3Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
4Upstream-Status: Pending
5
6--- a/bin/automake.in
7+++ b/bin/automake.in
8@@ -272,6 +272,9 @@
9 # $AM_CONFIG_AUX_DIR is prefixed with $(top_srcdir), so it can be used
10 # in Makefiles.
11 my $am_config_aux_dir = '';
12+# Directory used at runtime like running test-driver that should not
13+# depend on $(top_srcdir)
14+my $am_config_rt_aux_dir = '';
15
16 # Directory to search for AC_LIBSOURCE files, as set by AC_CONFIG_LIBOBJ_DIR
17 # in configure.ac.
18@@ -4700,7 +4703,7 @@
19 {
20 require_conf_file ("parallel-tests", FOREIGN, 'test-driver');
21 define_variable ("${pfx}LOG_DRIVER",
22- "\$(SHELL) $am_config_aux_dir/test-driver",
23+ "\$(SHELL) $am_config_rt_aux_dir/test-driver",
24 INTERNAL);
25 }
26 my $driver = '$(' . $pfx . 'LOG_DRIVER)';
27@@ -7284,6 +7287,10 @@
28 $am_config_aux_dir =
29 '$(top_srcdir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
30 $am_config_aux_dir =~ s,/*$,,;
31+
32+ $am_config_rt_aux_dir =
33+ '$(top_builddir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
34+ $am_config_rt_aux_dir =~ s,/*$,,;
35 }
diff --git a/recipes-devtools/automake/automake_1.14.1.bbappend b/recipes-devtools/automake/automake_1.14.1.bbappend
new file mode 100644
index 0000000..c3f22b8
--- /dev/null
+++ b/recipes-devtools/automake/automake_1.14.1.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " \
4 file://new_rt_path_for_test-driver.patch \
5 "