summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/connman/connman/connman.patch
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-01-29 14:12:23 +0100
committerNora Björklund <nora.bjorklund@enea.com>2016-02-08 14:30:51 +0100
commitb878cf381de0a0d158f1e97cf8726ea1756fd2fa (patch)
tree24cd38525e85e9de3a58b2a5034f368eb86ec117 /recipes-connectivity/connman/connman/connman.patch
parentde0b35a0d18ec23b7be6b0bde88b3254c951d6ac (diff)
downloadmeta-el-common-b878cf381de0a0d158f1e97cf8726ea1756fd2fa.tar.gz
connman: Rewrite to a patch to the connman file
The original .bbappend was adding a new "connman" file that replaced the one provided in the original recipe. This meant that any changes in the original file from poky would be overwritten. The .bbappend now patches the connman file so that any changes in it are either included or caught with merge conflict. To achieve this I did an artifice of copying the connman file in S to be patched by do_patch, then copied it back in WORKDIR to be installed on target by do_install. Also renamed the recipe .bbappend to cover all versions of connman and renamed the files folder. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Nora Björklund <nora.bjorklund@enea.com>
Diffstat (limited to 'recipes-connectivity/connman/connman/connman.patch')
-rw-r--r--recipes-connectivity/connman/connman/connman.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-connectivity/connman/connman/connman.patch b/recipes-connectivity/connman/connman/connman.patch
new file mode 100644
index 0000000..e3ff2f9
--- /dev/null
+++ b/recipes-connectivity/connman/connman/connman.patch
@@ -0,0 +1,18 @@
1--- ./connman.orig 2016-01-28 17:03:08.000315610 +0100
2+++ ./connman 2016-01-28 17:05:24.393956927 +0100
3@@ -36,13 +36,13 @@ do_start() {
4 if [ "$NET_ADDR" = dhcp ]; then
5 ethn=`ifconfig | grep "^eth" | sed -e "s/\(eth[0-9]\)\(.*\)/\1/"`
6 if [ ! -z "$ethn" ]; then
7- EXTRA_PARAM="-I $ethn"
8+ EXTRA_PARAM="--noipconfig $ethn"
9 fi
10 else
11 for i in $NET_DEVS; do
12 ADDR=`ifconfig $i | sed 's/addr://g' | sed -ne 's/^.*inet \([0-9.]*\) .*$/\1/p'`
13 if [ "$NET_ADDR" = "$ADDR" ]; then
14- EXTRA_PARAM="-I $i"
15+ EXTRA_PARAM="--noipconfig $i"
16 break
17 fi
18 done