summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2016-02-08 15:24:30 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2016-02-24 13:21:46 +0100
commite60b73ff643117137ca42534f013784b61d0f0fc (patch)
tree0ebcfd84c86c91b11c7873d8dea4168cf842f51e
parent1b9f0ecd3062007111db53568d04b796fe0f15da (diff)
downloadmeta-el-common-e60b73ff643117137ca42534f013784b61d0f0fc.tar.gz
valgrind: drop the bbappend
These workarounds were needed because Power ISA 2.07 was not supported in GCC 4.8.2 (introduced in GCC 4.9). GCC 4.8 support has been dropped from poky master since commit d9aabf9639510fdb3e2ccc21ba5ae4aa9f6e4a57. Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch48
-rw-r--r--recipes-devtools/valgrind/valgrind_3.9.0.bbappend30
2 files changed, 0 insertions, 78 deletions
diff --git a/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch b/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch
deleted file mode 100644
index 88a8a54..0000000
--- a/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1valgrind: Disable Power ISA 2.07 check
2
3The Power ISA 2.07 check fails when not supported by both machine
4architecture and gcc.
5
6Upstream-Status: Inappropriate [disable feature]
7
8Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
9
10--- a/configure.ac 2014-05-05 17:06:29.674630565 +0200
11+++ b/configure.ac 2014-05-06 13:16:47.525598513 +0200
12@@ -1316,18 +1316,25 @@
13 AM_CONDITIONAL(BUILD_DFP_TESTS, test x$ac_gcc_have_dfp_type = xyes)
14
15 # isa 2.07 checking
16-AC_MSG_CHECKING([that assembler knows ISA 2.07 ])
17+AC_ARG_ENABLE([isa_2_07_check],
18+ [AS_HELP_STRING([--disable-isa_2_07_check],
19+ [disable Power ISA 2.07 check])],
20+ [],
21+ [disable_isa_2_07_check=no])
22
23-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
24-]], [[
25- __asm__ __volatile__("mtvsrd 1,2 ");
26-]])], [
27-ac_asm_have_isa_2_07=yes
28-AC_MSG_RESULT([yes])
29-], [
30-ac_asm_have_isa_2_07=no
31-AC_MSG_RESULT([no])
32-])
33+AS_IF([test "x$disable_isa_2_07_check" = xno],
34+ [AC_MSG_CHECKING([that assembler knows ISA 2.07 ])
35+
36+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
37+ ]], [[
38+ __asm__ __volatile__("mtvsrd 1,2 ");
39+ ]])], [
40+ ac_asm_have_isa_2_07=yes
41+ AC_MSG_RESULT([yes])
42+ ], [
43+ ac_asm_have_isa_2_07=no
44+ AC_MSG_RESULT([no])
45+ ])])
46
47 AM_CONDITIONAL(HAS_ISA_2_07, test x$ac_asm_have_isa_2_07 = xyes)
48
diff --git a/recipes-devtools/valgrind/valgrind_3.9.0.bbappend b/recipes-devtools/valgrind/valgrind_3.9.0.bbappend
deleted file mode 100644
index 4af368d..0000000
--- a/recipes-devtools/valgrind/valgrind_3.9.0.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
1EXTRA_OECONF_append_b4860qds-64b = " --disable-isa_2_07_check"
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
4
5SRC_URI += "\
6 file://disable-power-isa-2.07-check.patch \
7 "
8
9do_compile_ptest_zc702-zynq7-prt() {
10 # This is to replace the ptest building part that fails due to
11 # internal compiler error on ARM targets (LXCR-3358)
12 echo ""
13}
14
15do_compile_ptest_zc702-zynq7() {
16 # This is to replace the ptest building part that fails due to
17 # internal compiler error on ARM targets (LXCR-3358)
18 echo ""
19}
20
21do_compile_ptest_k2hk-evm() {
22 # This is to replace the ptest building part that fails due to
23 # internal compiler error on ARM targets (LXCR-3358)
24 echo ""
25}
26do_compile_ptest_proliant-m800() {
27 # This is to replace the ptest building part that fails due to
28 # internal compiler error on ARM targets (LXCR-3358)
29 echo ""
30}