summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2016-02-03 13:01:48 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2016-02-05 16:00:07 +0100
commitde0b35a0d18ec23b7be6b0bde88b3254c951d6ac (patch)
tree8bcd1c1a1102cfa59a05b0aee679b8abdbe1a729
parenta3d7259395fefc721534fc063ada9d6eadd66128 (diff)
downloadmeta-el-common-de0b35a0d18ec23b7be6b0bde88b3254c951d6ac.tar.gz
python-smartpm: drop the bbappend
The patch exists on poky master since commit e5a11759d8d6f15191167ab1f3ffb3db8b6715aa Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-devtools/python/python-smartpm/smart-already-installed-message.patch54
-rw-r--r--recipes-devtools/python/python-smartpm_1.4.1.bbappend5
2 files changed, 0 insertions, 59 deletions
diff --git a/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch b/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
deleted file mode 100644
index e264de8..0000000
--- a/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1
2From a74a9a9eb9d75964a0e978950e8b191d7a18d763 Mon Sep 17 00:00:00 2001
3From: Paul Eggleton <paul.eggleton@linux.intel.com>
4Date: Fri, 5 Jun 2015 17:07:16 +0100
5Subject: [PATCH] smart: change "is already installed" message from warning to
6 info
7
8This doesn't need to be a warning.
9
10Upstream-Status: Pending
11
12Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
13---
14 smart/commands/install.py | 4 ++--
15 smart/interfaces/text/interactive.py | 2 +-
16 2 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/smart/commands/install.py b/smart/commands/install.py
19index 6ef9682..80d456b 100644
20--- a/smart/commands/install.py
21+++ b/smart/commands/install.py
22@@ -152,7 +152,7 @@ def main(ctrl, opts):
23 for obj in results:
24 for pkg in obj.packages:
25 if pkg.installed:
26- iface.warning(_("%s (for %s) is already installed")
27+ iface.info(_("%s (for %s) is already installed")
28 % (pkg, arg))
29 installed = True
30 break
31@@ -184,7 +184,7 @@ def main(ctrl, opts):
32 for name in names:
33 pkg = names[name][0]
34 if pkg.installed:
35- iface.warning(_("%s is already installed") % pkg)
36+ iface.info(_("%s is already installed") % pkg)
37 else:
38 trans.enqueue(pkg, INSTALL)
39
40diff --git a/smart/interfaces/text/interactive.py b/smart/interfaces/text/interactive.py
41index 9865584..190867b 100644
42--- a/smart/interfaces/text/interactive.py
43+++ b/smart/interfaces/text/interactive.py
44@@ -278,7 +278,7 @@ class Interpreter(Cmd):
45 for name in names:
46 pkg = names[name][0]
47 if pkg.installed:
48- iface.warning(_("%s is already installed") % pkg)
49+ iface.info(_("%s is already installed") % pkg)
50 else:
51 found = True
52 transaction.enqueue(pkg, INSTALL)
53--
542.1.0
diff --git a/recipes-devtools/python/python-smartpm_1.4.1.bbappend b/recipes-devtools/python/python-smartpm_1.4.1.bbappend
deleted file mode 100644
index 1148437..0000000
--- a/recipes-devtools/python/python-smartpm_1.4.1.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "\
4 file://smart-already-installed-message.patch \
5"