summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2016-04-13 02:48:13 +0200
committerTudor Florea <tudor.florea@enea.com>2016-04-13 10:07:49 +0200
commitd6a7f248063239c3b45e3ec139e7a8dd32b53b90 (patch)
tree5e21bad0c6a03669da8eb210af51611a1c581ded
parent88a73cdc79d09dc66a7767c102770258d08ac043 (diff)
downloadmeta-el-common-d6a7f248063239c3b45e3ec139e7a8dd32b53b90.tar.gz
ltp: remove patches integrated in poky
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
-rw-r--r--recipes-extended/ltp/ltp/fix-test_proc_kill-hang.patch23
-rw-r--r--recipes-extended/ltp/ltp/periodic_output.patch31
-rw-r--r--recipes-extended/ltp/ltp_%.bbappend7
3 files changed, 0 insertions, 61 deletions
diff --git a/recipes-extended/ltp/ltp/fix-test_proc_kill-hang.patch b/recipes-extended/ltp/ltp/fix-test_proc_kill-hang.patch
deleted file mode 100644
index 8fb11af..0000000
--- a/recipes-extended/ltp/ltp/fix-test_proc_kill-hang.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Fix test_proc_kill hanging
2
3Sometimes the signal is delivered to memcg_process before the framework took
4into consideration its pid entered in the tasks. Fixed by delaying the signal
5send command.
6
7Signed-off-by: George Nita <george.nita@enea.com>
8Upstream-Status: Not Submitted
9
10diff --git a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
11index ffbe006..e81bf74 100755
12--- a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
13+++ b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
14@@ -220,8 +220,8 @@ test_proc_kill()
15
16 $TEST_PATH/memcg_process $2 -s $3 &
17 pid=$!
18- sleep 1
19 echo $pid > tasks
20+ sleep 1
21
22 kill -s USR1 $pid 2> /dev/null
23 sleep 1
diff --git a/recipes-extended/ltp/ltp/periodic_output.patch b/recipes-extended/ltp/ltp/periodic_output.patch
deleted file mode 100644
index 153fe83..0000000
--- a/recipes-extended/ltp/ltp/periodic_output.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1Add periodic output for long time test.
2
3Signed-off-by: Tudor Florea <tudor.florea@enea.com>
4Upstream-Status: Pending
5
6diff -ruN a/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh b/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh
7--- a/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh 2013-11-08 15:54:09.515049081 +0100
8+++ b/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh 2013-11-08 22:32:15.587370406 +0100
9@@ -37,7 +37,8 @@
10 exit 0
11 fi
12
13-RUN_TIME=$(( 60 * 60 ))
14+ONE_MINUTE=60
15+RUN_TIME=60
16
17 cleanup()
18 {
19@@ -81,7 +82,11 @@
20 eval /bin/kill -s SIGUSR1 \$pid$i 2> /dev/null
21 done
22
23- sleep $4
24+ for i in $(seq 0 $RUN_TIME-1)
25+ do
26+ eval echo "Started $i min ago. Still alive... "
27+ sleep $ONE_MINUTE
28+ done
29
30 for i in $(seq 0 $(($1-1)))
31 do
diff --git a/recipes-extended/ltp/ltp_%.bbappend b/recipes-extended/ltp/ltp_%.bbappend
index bdfae82..59a4341 100644
--- a/recipes-extended/ltp/ltp_%.bbappend
+++ b/recipes-extended/ltp/ltp_%.bbappend
@@ -1,10 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/ltp:"
2
3SRC_URI_append = " \
4 file://periodic_output.patch \
5 file://fix-test_proc_kill-hang.patch \
6 "
7
8do_compile_prepend () { 1do_compile_prepend () {
9 ( make -C ${B}/testcases/open_posix_testsuite generate-makefiles conformance-all tools-all functional-all stress-all ) 2 ( make -C ${B}/testcases/open_posix_testsuite generate-makefiles conformance-all tools-all functional-all stress-all )
10} 3}