summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Sicleru <stefan.sicleru@enea.com>2016-03-07 13:43:33 +0100
committerMartin Borg <martin.borg@enea.com>2016-03-09 15:36:12 +0100
commit3d8b87c0eeb213b43fc97b1e4b0ff3df3fd1468a (patch)
tree507a19758e27741fd4e8b0cfc924778617d36845
parente39a57bd9aadc087279cc71376d357969a5a5bea (diff)
downloadmeta-el-common-3d8b87c0eeb213b43fc97b1e4b0ff3df3fd1468a.tar.gz
packagegroups: remove enea-core-boot
packagroup-enea-core-boot was a legacy from older releases, all of its useful content can be found in packagegroup-core-boot from poky Signed-off-by: Stefan Sicleru <stefan.sicleru@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com>
-rw-r--r--images/enea-image-common.inc2
-rw-r--r--recipes-core/packagegroups/packagegroup-enea-core-boot.bb65
2 files changed, 1 insertions, 66 deletions
diff --git a/images/enea-image-common.inc b/images/enea-image-common.inc
index 2f063eb..b94be17 100644
--- a/images/enea-image-common.inc
+++ b/images/enea-image-common.inc
@@ -1,7 +1,7 @@
1IMAGE_FEATURES += "ssh-server-dropbear package-management" 1IMAGE_FEATURES += "ssh-server-dropbear package-management"
2 2
3IMAGE_INSTALL = " \ 3IMAGE_INSTALL = " \
4 packagegroup-enea-core-boot \ 4 packagegroup-core-boot \
5 " 5 "
6 6
7IMAGE_LINGUAS = "" 7IMAGE_LINGUAS = ""
diff --git a/recipes-core/packagegroups/packagegroup-enea-core-boot.bb b/recipes-core/packagegroups/packagegroup-enea-core-boot.bb
deleted file mode 100644
index ee762e9..0000000
--- a/recipes-core/packagegroups/packagegroup-enea-core-boot.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4
5SUMMARY = "Minimal boot requirements"
6DESCRIPTION = "The minimal and busybox set of packages required to boot the system"
7LICENSE = "MIT"
8DEPENDS = "virtual/kernel"
9PR = "r11"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12
13inherit packagegroup
14
15#
16# Set by the machine configuration with packages essential for device bootup
17#
18MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
19MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
20
21# For backwards compatibility after rename
22RPROVIDES_${PN} = "task-core-boot"
23RREPLACES_${PN} = "task-core-boot"
24RCONFLICTS_${PN} = "task-core-boot"
25
26# Distro can override the following VIRTUAL-RUNTIME providers:
27VIRTUAL-RUNTIME_dev_manager ?= "udev"
28VIRTUAL-RUNTIME_login_manager ?= "busybox"
29VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
30VIRTUAL-RUNTIME_initscripts ?= "initscripts"
31VIRTUAL-RUNTIME_keymaps ?= "keymaps"
32
33RDEPENDS_${PN} += "\
34 base-files \
35 base-passwd \
36 ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
37 modutils-initscripts \
38 netbase \
39 init-ifupdown \
40 ${VIRTUAL-RUNTIME_login_manager} \
41 ${VIRTUAL-RUNTIME_init_manager} \
42 ${VIRTUAL-RUNTIME_initscripts} \
43 ${VIRTUAL-RUNTIME_dev_manager} \
44 ${VIRTUAL-RUNTIME_update-alternatives} \
45 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
46
47RDEPENDS_${PN}_append_fslmachine = " u-boot"
48RDEPENDS_${PN}_append_p2041 = " rcw"
49RDEPENDS_${PN}_append_p4080 = " rcw"
50RDEPENDS_${PN} += "\
51 busybox \
52 ${@base_contains("MACHINE_FEATURES", "rtc", "busybox-hwclock", "", d)} \
53 "
54
55RDEPENDS_${PN}_append_x86 = "\
56 kernel-vmlinux \
57 kernel \
58 "
59RDEPENDS_${PN}_append_x86-64 = "\
60 kernel-vmlinux \
61 kernel \
62 "
63
64RRECOMMENDS_${PN} = "\
65 ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"