summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-01-26 15:51:12 +0100
committerNora Björklund <nora.bjorklund@enea.com>2016-01-28 12:35:18 +0100
commit32bee1d3e66c17bf2cedfbd19e658a767db81c82 (patch)
treee30c55184aac85f2f2e7e6eb8b643e6dcef90864
parente7bd5556a12c8108a67ddf2852a0b58d615fea3c (diff)
downloadmeta-el-common-32bee1d3e66c17bf2cedfbd19e658a767db81c82.tar.gz
openssh: remove bbappend
The ptest patch is apparently not relevant anymore. Although the original commit doesn't specify what the errors were, I ported the patch to openssh_7.1p2 and ran the ptests with and without the patch. The output was identical regardless. There were some errors, but unrelated to the patch changes. So I'm dropping the patch for now. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Nora Björklund <nora.bjorklund@enea.com>
-rw-r--r--recipes-connectivity/openssh/openssh/openssh-ptest-fix-sshconnect.patch57
-rw-r--r--recipes-connectivity/openssh/openssh_6.6p1.bbappend3
2 files changed, 0 insertions, 60 deletions
diff --git a/recipes-connectivity/openssh/openssh/openssh-ptest-fix-sshconnect.patch b/recipes-connectivity/openssh/openssh/openssh-ptest-fix-sshconnect.patch
deleted file mode 100644
index 0913701..0000000
--- a/recipes-connectivity/openssh/openssh/openssh-ptest-fix-sshconnect.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1Fixed openssh ptest
2
3ptests for openssh, apart from a lot of .sh scripts, also
4require 2 executables to be cross-compiled for the target
5and deployed there, that will be called from the test
6scripts.
7
8Those 2 files were not built when cross-compiling
9(Makefile target all:), so I added them to the build,
10under the target all_test.
11
12This new make target is intended to be run from
13do_compile_ptest(), that builds everything needed for
14performing the ptests.
15
16Because both these 2 executables required for ptest
17are linked with libssh (LDFLAGS += -lssh), I also
18added it as dependency for each of them.
19
20Upstream-status: Inappropriate
21
22Signed-off-by: Liviu Gheorghisan <liviu.gheorghisan@enea.com>
23---
24--- a/Makefile.in 2014-12-10 16:19:37.513373454 +0100
25+++ b/Makefile.in 2014-12-10 16:25:23.262764227 +0100
26@@ -130,6 +130,8 @@ FIXALGORITHMSCMD= $(SHELL) $(srcdir)/fix
27
28 all: $(CONFIGFILES) $(MANPAGES) $(TARGETS)
29
30+all_test: regress/modpipe$(EXEEXT) regress/setuid-allowed$(EXEEXT)
31+
32 $(LIBSSH_OBJS): Makefile.in config.h
33 $(SSHOBJS): Makefile.in config.h
34 $(SSHDOBJS): Makefile.in config.h
35@@ -394,18 +396,18 @@ uninstall:
36 -rm -f $(DESTDIR)$(mandir)/$(mansubdir)8/ssh-pkcs11-helper.8
37 -rm -f $(DESTDIR)$(mandir)/$(mansubdir)1/slogin.1
38
39-regress/modpipe$(EXEEXT): $(srcdir)/regress/modpipe.c
40+regress/modpipe$(EXEEXT): libssh.a
41 [ -d `pwd`/regress ] || mkdir -p `pwd`/regress
42 [ -f `pwd`/regress/Makefile ] || \
43 ln -s `cd $(srcdir) && pwd`/regress/Makefile `pwd`/regress/Makefile
44- $(CC) $(CFLAGS) $(CPPFLAGS) -o $@ $? \
45+ $(CC) $(CFLAGS) $(CPPFLAGS) -o $@ $(srcdir)/regress/modpipe.c \
46 $(LDFLAGS) -lssh -lopenbsd-compat -lssh -lopenbsd-compat $(LIBS)
47
48-regress/setuid-allowed$(EXEEXT): $(srcdir)/regress/setuid-allowed.c
49+regress/setuid-allowed$(EXEEXT): libssh.a
50 [ -d `pwd`/regress ] || mkdir -p `pwd`/regress
51 [ -f `pwd`/regress/Makefile ] || \
52 ln -s `cd $(srcdir) && pwd`/regress/Makefile `pwd`/regress/Makefile
53- $(CC) $(CFLAGS) $(CPPFLAGS) -o $@ $? \
54+ $(CC) $(CFLAGS) $(CPPFLAGS) -o $@ $(srcdir)/regress/setuid-allowed.c \
55 $(LDFLAGS) -lssh -lopenbsd-compat -lssh -lopenbsd-compat $(LIBS)
56
57 tests interop-tests: $(TARGETS) regress/modpipe$(EXEEXT) regress/setuid-allowed$(EXEEXT)
diff --git a/recipes-connectivity/openssh/openssh_6.6p1.bbappend b/recipes-connectivity/openssh/openssh_6.6p1.bbappend
deleted file mode 100644
index 2e8ca80..0000000
--- a/recipes-connectivity/openssh/openssh_6.6p1.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://openssh-ptest-fix-sshconnect.patch \