summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCatalina Focsa <catalina.focsa@enea.com>2015-12-17 15:52:26 +0100
committerGeorge Nita <george.nita@enea.com>2015-12-17 15:56:00 +0100
commita43271bc9283128d82c6542c70378a52a05d35cf (patch)
tree62a422438fd863f1ac6542ed118b72ee33ed8ebf
parente13c24fe6b788fba5334813b0dc7922e8ab803a2 (diff)
downloadmeta-el-common-dizzy.tar.gz
ltp: Fix test_proc_kill hangingdizzy
Signed-off-by: Catalina Focsa <catalina.focsa@enea.com> Signed-off-by: George Nita <george.nita@enea.com>
-rw-r--r--recipes-extended/ltp/files/fix-test_proc_kill-hang.patch23
-rw-r--r--recipes-extended/ltp/ltp_20140422.bbappend3
2 files changed, 25 insertions, 1 deletions
diff --git a/recipes-extended/ltp/files/fix-test_proc_kill-hang.patch b/recipes-extended/ltp/files/fix-test_proc_kill-hang.patch
new file mode 100644
index 0000000..8fb11af
--- /dev/null
+++ b/recipes-extended/ltp/files/fix-test_proc_kill-hang.patch
@@ -0,0 +1,23 @@
1Fix test_proc_kill hanging
2
3Sometimes the signal is delivered to memcg_process before the framework took
4into consideration its pid entered in the tasks. Fixed by delaying the signal
5send command.
6
7Signed-off-by: George Nita <george.nita@enea.com>
8Upstream-Status: Not Submitted
9
10diff --git a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
11index ffbe006..e81bf74 100755
12--- a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
13+++ b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
14@@ -220,8 +220,8 @@ test_proc_kill()
15
16 $TEST_PATH/memcg_process $2 -s $3 &
17 pid=$!
18- sleep 1
19 echo $pid > tasks
20+ sleep 1
21
22 kill -s USR1 $pid 2> /dev/null
23 sleep 1
diff --git a/recipes-extended/ltp/ltp_20140422.bbappend b/recipes-extended/ltp/ltp_20140422.bbappend
index 1163fde..e0b6de0 100644
--- a/recipes-extended/ltp/ltp_20140422.bbappend
+++ b/recipes-extended/ltp/ltp_20140422.bbappend
@@ -1,7 +1,8 @@
1FILESEXTRAPATHS_append := "${THISDIR}/files" 1FILESEXTRAPATHS_append := "${THISDIR}/files"
2 2
3SRC_URI += " \ 3SRC_URI_append = " \
4 file://periodic_output.patch \ 4 file://periodic_output.patch \
5 file://fix-test_proc_kill-hang.patch \
5 " 6 "
6 7
7do_compile_prepend () { 8do_compile_prepend () {