summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_23.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_23.11.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_23.11.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-extended/dpdk/dpdk_23.11.bb b/recipes-extended/dpdk/dpdk_23.11.bb
index 5f0f9ec..fc2796a 100644
--- a/recipes-extended/dpdk/dpdk_23.11.bb
+++ b/recipes-extended/dpdk/dpdk_23.11.bb
@@ -9,8 +9,11 @@ S = "${WORKDIR}/git"
9 9
10def get_cpu_instruction_set(bb, d): 10def get_cpu_instruction_set(bb, d):
11 import re 11 import re
12 march = re.search(r'-march=([^\s]*)', d.getVar('CC')).group(1) 12 march = re.search(r'-march=([^\s]*)', d.getVar('CC'))
13 return march 13 if march:
14 return march.group(1)
15 else:
16 return "core2"
14 17
15EXTRA_OEMESON = " -Dexamples=all -Dcpu_instruction_set=${@get_cpu_instruction_set(bb, d)} " 18EXTRA_OEMESON = " -Dexamples=all -Dcpu_instruction_set=${@get_cpu_instruction_set(bb, d)} "
16 19