summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_23.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_23.07.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_23.07.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_23.07.bb b/recipes-extended/dpdk/dpdk_23.07.bb
new file mode 100644
index 0000000..3a1b0a8
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_23.07.bb
@@ -0,0 +1,67 @@
1include dpdk.inc
2
3SRC_URI = "git://dpdk.org/git/dpdk;branch=${BRANCH};protocol=https \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto-21.11.patch \
5"
6
7BRANCH = "releases"
8SRCREV = "12fcafcd62286933e6b167b14856d21f642efa5f"
9S = "${WORKDIR}/git"
10
11# kernel module is provide by dpdk-module recipe, so disable here
12EXTRA_OEMESON = " -Denable_kmods=false \
13 -Dexamples=all \
14"
15
16COMPATIBLE_MACHINE = "null"
17COMPATIBLE_HOST:libc-musl:class-target = "null"
18COMPATIBLE_HOST:linux-gnux32 = "null"
19
20PACKAGECONFIG ??= " "
21PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
22PACKAGECONFIG[libvirt] = ",,libvirt"
23
24RDEPENDS:${PN} += "pciutils python3-core"
25RDEPENDS:${PN}-examples += "bash"
26DEPENDS = "numactl python3-pyelftools-native"
27
28inherit meson pkgconfig
29
30INSTALL_PATH = "${prefix}/share/dpdk"
31
32do_install:append(){
33 # remove source files
34 rm -rf ${D}/${INSTALL_PATH}/examples/*
35
36 # Install examples
37 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
38 for dirname in ${B}/examples/dpdk-*
39 do
40 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
41 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
42 fi
43 done
44
45}
46
47PACKAGES =+ "${PN}-examples ${PN}-tools"
48
49FILES:${PN} += " ${bindir}/dpdk-testpmd \
50 ${bindir}/dpdk-proc-info \
51 ${libdir}/*.so* \
52 ${libdir}/dpdk/pmds-22.0/*.so* \
53 "
54FILES:${PN}-examples = " \
55 ${prefix}/share/dpdk/examples/* \
56 "
57
58FILES:${PN}-tools = " \
59 ${bindir}/dpdk-pdump \
60 ${bindir}/dpdk-test \
61 ${bindir}/dpdk-test-* \
62 ${bindir}/dpdk-*.py \
63 "
64
65CVE_PRODUCT = "data_plane_development_kit"
66
67INSANE_SKIP:${PN} = "dev-so"