summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_22.07.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_22.07.0.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_22.07.0.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_22.07.0.bb b/recipes-extended/dpdk/dpdk_22.07.0.bb
new file mode 100644
index 0000000..bbaa847
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_22.07.0.bb
@@ -0,0 +1,76 @@
1include dpdk.inc
2
3SRC_URI = "git://dpdk.org/dpdk;branch=${BRANCH};protocol=https \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto-21.11.patch \
5"
6
7BRANCH = "releases"
8SRCREV = "4fceceed5b5e9fbf04acffd66239c79d81e79260"
9S = "${WORKDIR}/git"
10
11# CVE-2021-3839 has been fixed by commit 4c40d30d2b in 21.11.1
12# NVD database is incomplete
13# CVE-2022-0669 has been fixed by commit 6cb68162e4 in 21.11.1
14# NVD database is incomplete
15CVE_CHECK_IGNORE += "\
16 CVE-2021-3839 \
17 CVE-2022-0669 \
18"
19
20# kernel module is provide by dpdk-module recipe, so disable here
21EXTRA_OEMESON = " -Denable_kmods=false \
22 -Dexamples=all \
23"
24
25COMPATIBLE_MACHINE = "null"
26COMPATIBLE_HOST:libc-musl:class-target = "null"
27COMPATIBLE_HOST:linux-gnux32 = "null"
28
29PACKAGECONFIG ??= " "
30PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
31PACKAGECONFIG[libvirt] = ",,libvirt"
32
33RDEPENDS:${PN} += "pciutils python3-core"
34RDEPENDS:${PN}-examples += "bash"
35DEPENDS = "numactl python3-pyelftools-native"
36
37inherit meson pkgconfig
38
39INSTALL_PATH = "${prefix}/share/dpdk"
40
41do_install:append(){
42 # remove source files
43 rm -rf ${D}/${INSTALL_PATH}/examples/*
44
45 # Install examples
46 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
47 for dirname in ${B}/examples/dpdk-*
48 do
49 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
50 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
51 fi
52 done
53
54}
55
56PACKAGES =+ "${PN}-examples ${PN}-tools"
57
58FILES:${PN} += " ${bindir}/dpdk-testpmd \
59 ${bindir}/dpdk-proc-info \
60 ${libdir}/*.so* \
61 ${libdir}/dpdk/pmds-22.0/*.so* \
62 "
63FILES:${PN}-examples = " \
64 ${prefix}/share/dpdk/examples/* \
65 "
66
67FILES:${PN}-tools = " \
68 ${bindir}/dpdk-pdump \
69 ${bindir}/dpdk-test \
70 ${bindir}/dpdk-test-* \
71 ${bindir}/dpdk-*.py \
72 "
73
74CVE_PRODUCT = "data_plane_development_kit"
75
76INSANE_SKIP:${PN} = "dev-so"