summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_21.11.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_21.11.4.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_21.11.4.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_21.11.4.bb b/recipes-extended/dpdk/dpdk_21.11.4.bb
new file mode 100644
index 0000000..bedfa5b
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_21.11.4.bb
@@ -0,0 +1,77 @@
1include dpdk.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto-21.11.patch \
5"
6
7STABLE = "-stable"
8BRANCH = "21.11"
9SRCREV = "e185150c2ada84e637d14274ec456a3a4965487e"
10S = "${WORKDIR}/git"
11
12# CVE-2021-3839 has been fixed by commit 4c40d30d2b in 21.11.1
13# NVD database is incomplete
14# CVE-2022-0669 has been fixed by commit 6cb68162e4 in 21.11.1
15# NVD database is incomplete
16CVE_CHECK_IGNORE += "\
17 CVE-2021-3839 \
18 CVE-2022-0669 \
19"
20
21# kernel module is provide by dpdk-module recipe, so disable here
22EXTRA_OEMESON = " -Denable_kmods=false \
23 -Dexamples=all \
24"
25
26COMPATIBLE_MACHINE = "null"
27COMPATIBLE_HOST:libc-musl:class-target = "null"
28COMPATIBLE_HOST:linux-gnux32 = "null"
29
30PACKAGECONFIG ??= " "
31PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
32PACKAGECONFIG[libvirt] = ",,libvirt"
33
34RDEPENDS:${PN} += "pciutils python3-core"
35RDEPENDS:${PN}-examples += "bash"
36DEPENDS = "numactl python3-pyelftools-native"
37
38inherit meson pkgconfig
39
40INSTALL_PATH = "${prefix}/share/dpdk"
41
42do_install:append(){
43 # remove source files
44 rm -rf ${D}/${INSTALL_PATH}/examples/*
45
46 # Install examples
47 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
48 for dirname in ${B}/examples/dpdk-*
49 do
50 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
51 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
52 fi
53 done
54
55}
56
57PACKAGES =+ "${PN}-examples ${PN}-tools"
58
59FILES:${PN} += " ${bindir}/dpdk-testpmd \
60 ${bindir}/dpdk-proc-info \
61 ${libdir}/*.so* \
62 ${libdir}/dpdk/pmds-22.0/*.so* \
63 "
64FILES:${PN}-examples = " \
65 ${prefix}/share/dpdk/examples/* \
66 "
67
68FILES:${PN}-tools = " \
69 ${bindir}/dpdk-pdump \
70 ${bindir}/dpdk-test \
71 ${bindir}/dpdk-test-* \
72 ${bindir}/dpdk-*.py \
73 "
74
75CVE_PRODUCT = "data_plane_development_kit"
76
77INSANE_SKIP:${PN} = "dev-so"