summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_21.11.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_21.11.2.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_21.11.2.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_21.11.2.bb b/recipes-extended/dpdk/dpdk_21.11.2.bb
new file mode 100644
index 0000000..570648a
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_21.11.2.bb
@@ -0,0 +1,74 @@
1include dpdk.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto-21.11.patch \
5"
6
7STABLE = "-stable"
8BRANCH = "21.11"
9SRCREV = "7bcd45ce824d0ea2a9f30d16855613a93521851b"
10S = "${WORKDIR}/git"
11
12# CVE-2021-3839 has been fixed by commit 4c40d30d2b in 21.11.1
13# NVD database is incomplete
14CVE_CHECK_IGNORE += "\
15 CVE-2021-3839 \
16"
17
18# kernel module is provide by dpdk-module recipe, so disable here
19EXTRA_OEMESON = " -Denable_kmods=false \
20 -Dexamples=all \
21"
22
23COMPATIBLE_MACHINE = "null"
24COMPATIBLE_HOST:libc-musl:class-target = "null"
25COMPATIBLE_HOST:linux-gnux32 = "null"
26
27PACKAGECONFIG ??= " "
28PACKAGECONFIG[afxdp] = ",,libbpf"
29PACKAGECONFIG[libvirt] = ",,libvirt"
30
31RDEPENDS:${PN} += "pciutils python3-core"
32RDEPENDS:${PN}-examples += "bash"
33DEPENDS = "numactl python3-pyelftools-native"
34
35inherit meson
36
37INSTALL_PATH = "${prefix}/share/dpdk"
38
39do_install:append(){
40 # remove source files
41 rm -rf ${D}/${INSTALL_PATH}/examples/*
42
43 # Install examples
44 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
45 for dirname in ${B}/examples/dpdk-*
46 do
47 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
48 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
49 fi
50 done
51
52}
53
54PACKAGES =+ "${PN}-examples ${PN}-tools"
55
56FILES:${PN} += " ${bindir}/dpdk-testpmd \
57 ${bindir}/dpdk-proc-info \
58 ${libdir}/*.so* \
59 ${libdir}/dpdk/pmds-22.0/*.so* \
60 "
61FILES:${PN}-examples = " \
62 ${prefix}/share/dpdk/examples/* \
63 "
64
65FILES:${PN}-tools = " \
66 ${bindir}/dpdk-pdump \
67 ${bindir}/dpdk-test \
68 ${bindir}/dpdk-test-* \
69 ${bindir}/dpdk-*.py \
70 "
71
72CVE_PRODUCT = "data_plane_development_kit"
73
74INSANE_SKIP:${PN} = "dev-so"