summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_21.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_21.11.0.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_21.11.0.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_21.11.0.bb b/recipes-extended/dpdk/dpdk_21.11.0.bb
new file mode 100644
index 0000000..f7cdf0f
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_21.11.0.bb
@@ -0,0 +1,68 @@
1include dpdk.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto-21.11.patch \
5"
6
7STABLE = "-stable"
8BRANCH = "21.11"
9SRCREV = "45f04d88ae8fa6217812abdaa623d66b05fc7b6a"
10S = "${WORKDIR}/git"
11
12# kernel module is provide by dpdk-module recipe, so disable here
13EXTRA_OEMESON = " -Denable_kmods=false \
14 -Dexamples=all \
15"
16
17COMPATIBLE_MACHINE = "null"
18COMPATIBLE_HOST:libc-musl:class-target = "null"
19COMPATIBLE_HOST:linux-gnux32 = "null"
20
21PACKAGECONFIG ??= " "
22PACKAGECONFIG[afxdp] = ",,libbpf"
23PACKAGECONFIG[libvirt] = ",,libvirt"
24
25RDEPENDS:${PN} += "pciutils python3-core"
26RDEPENDS:${PN}-examples += "bash"
27DEPENDS = "numactl python3-pyelftools-native"
28
29inherit meson
30
31INSTALL_PATH = "${prefix}/share/dpdk"
32
33do_install:append(){
34 # remove source files
35 rm -rf ${D}/${INSTALL_PATH}/examples/*
36
37 # Install examples
38 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
39 for dirname in ${B}/examples/dpdk-*
40 do
41 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
42 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
43 fi
44 done
45
46}
47
48PACKAGES =+ "${PN}-examples ${PN}-tools"
49
50FILES:${PN} = " ${bindir}/dpdk-testpmd \
51 ${bindir}/dpdk-proc-info \
52 ${libdir}/*.so* \
53 ${libdir}/dpdk/pmds-22.0/*.so* \
54 "
55FILES:${PN}-examples = " \
56 ${prefix}/share/dpdk/examples/* \
57 "
58
59FILES:${PN}-tools = " \
60 ${bindir}/dpdk-pdump \
61 ${bindir}/dpdk-test \
62 ${bindir}/dpdk-test-* \
63 ${bindir}/dpdk-*.py \
64 "
65
66CVE_PRODUCT = "data_plane_development_kit"
67
68INSANE_SKIP:${PN} = "dev-so"