summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch b/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch
deleted file mode 100644
index 70a8dec..0000000
--- a/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From a385972c3675dd2b4792ab5b3cf7a536e6f9846c Mon Sep 17 00:00:00 2001
2From: Reshma Pattan <reshma.pattan@intel.com>
3Date: Thu, 2 May 2019 10:33:34 +0100
4Subject: [PATCH] mk: disable warning for packed member pointer
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9gcc 9 on Fedora 30 gives an error
10"taking address of packed member may result in an
11unaligned pointer value" warnings.
12
13For clang builds this warning is already disabled,
14so disable "-Waddress-of-packed-member" for gcc builds
15also.
16
17Snippet of build error:
18lib/librte_eal/linux/eal/eal_memalloc.c: In function ‘alloc_seg_walk’:
19lib/librte_eal/linux/eal/eal_memalloc.c:768:12: error:
20taking address of packed member of ‘struct rte_mem_config’ may result
21in an unaligned pointer value [-Werror=address-of-packed-member]
22 768 | cur_msl = &mcfg->memsegs[msl_idx];
23 | ^~~~~~~~~~~~~~~~~~~~~~~
24
25Signed-off-by: Reshma Pattan <reshma.pattan@intel.com>
26Tested-by: David Marchand <david.marchand@redhat.com>
27Upstream-Status: Backport
28Signed-off-by: He Zhe <zhe.he@windriver.com>
29---
30 mk/toolchain/gcc/rte.vars.mk | 3 +++
31 1 file changed, 3 insertions(+)
32
33diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
34index d8b99fa..b852fcf 100644
35--- a/mk/toolchain/gcc/rte.vars.mk
36+++ b/mk/toolchain/gcc/rte.vars.mk
37@@ -87,5 +87,8 @@ WERROR_FLAGS += -Wimplicit-fallthrough=2
38 WERROR_FLAGS += -Wno-format-truncation
39 endif
40
41+# disable packed member unalign warnings
42+WERROR_FLAGS += -Wno-address-of-packed-member
43+
44 export CC AS AR LD OBJCOPY OBJDUMP STRIP READELF
45 export TOOLCHAIN_CFLAGS TOOLCHAIN_LDFLAGS TOOLCHAIN_ASFLAGS
46--
472.7.4
48