summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
deleted file mode 100644
index 55f0c15..0000000
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 2 Sep 2016 15:48:52 +0800
4Subject: [PATCH] dpdk: fix for parellel make issue
5
6To make sure that the path of libraries should be correct and
7libraries will be build before, And available at the time of
8linking example apps.
9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11
12---
13 examples/Makefile | 1 +
14 examples/ethtool/ethtool-app/Makefile | 1 +
15 2 files changed, 2 insertions(+)
16
17diff --git a/examples/Makefile b/examples/Makefile
18index 17ecf7f64cda..2a8e805b85a7 100644
19--- a/examples/Makefile
20+++ b/examples/Makefile
21@@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app
22 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
23 DIRS-y += cmdline
24 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
25+DEPDIRS-y += examples/ethtool/lib
26 DIRS-y += ethtool
27 DIRS-y += exception_path
28 DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd
29diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
30index 4cd9efdd574b..d3c709ab2fef 100644
31--- a/examples/ethtool/ethtool-app/Makefile
32+++ b/examples/ethtool/ethtool-app/Makefile
33@@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c
34 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
35 CFLAGS += $(WERROR_FLAGS)
36
37+LDLIBS += -L$(ETHTOOL_LIB_PATH)/
38 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
39 LDLIBS += -lrte_ethtool
40