summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
deleted file mode 100644
index 18b761c..0000000
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From d08d11c8b6fdfe73884d67a94d907000afd136ed Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 19 Aug 2016 11:57:49 +0800
4Subject: [PATCH] dpdk: add --sysroot option within app makefile
5
6Upstream-Status: Inappropriate [configuration]
7
8rte.app.mk has been changed to add -Wl, to all items listed
9under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
10correctly when we depends on gcc to setup for GNU ld.
11
12Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
13
14---
15 mk/rte.app.mk | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/mk/rte.app.mk b/mk/rte.app.mk
19index 3eb41d176d21..9ab6688718db 100644
20--- a/mk/rte.app.mk
21+++ b/mk/rte.app.mk
22@@ -300,7 +300,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
23 ifeq ($(LINK_USING_CC),1)
24 O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(EXTRA_CFLAGS) $(OBJS-y) $(call linkerprefix, \
25 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
26- $(MAPFLAGS))
27+ $(MAPFLAGS)) $(SYSROOTPATH)
28 else
29 O_TO_EXE = $(LD) -o $@ $(OBJS-y) \
30 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \