summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb
new file mode 100644
index 0000000..6744554
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Utilities and example programs for use with XDP"
2HOMEPAGE = "https://github.com/xdp-project/xdp-tools"
3LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9ee53f8d06bbdb4c11b1557ecc4f8cd5 \
5 file://LICENSES/GPL-2.0;md5=994331978b428511800bfbd17eea3001 \
6 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd \
7 file://LICENSES/BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
8
9DEPENDS += " libbpf clang-native zlib elfutils libpcap"
10
11SRC_URI = "git://github.com/xdp-project/xdp-tools.git;branch=v1.2;protocol=https \
12 file://0001-configure-skip-toolchain-checks.patch \
13 file://0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch \
14 file://0003-Makefile-fix-KeyError-failure.patch \
15 file://0004-Makefile-fix-libxdp.pc-error.patch \
16 "
17
18SRCREV = "d4ff1f9bcf8b03556b625ab6e16958598482e861"
19
20S = "${WORKDIR}/git"
21
22inherit pkgconfig
23
24EXTRA_OEMAKE += "PREFIX=${D}${prefix}"
25
26export STAGING_INCDIR
27
28do_configure:prepend () {
29 export DYNAMIC_LIBXDP=1
30}
31
32do_install () {
33 oe_runmake install
34
35 # Remove object files *.o
36 rm -rf ${D}/${libdir}/bpf
37}
38
39RDEPENDS:${PN} += "bash"