summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk-module_23.03.bb
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-05-09 17:12:15 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2023-05-10 16:04:59 +0800
commit1a78228cf3c07f8166c4c2a317331ca8f1477906 (patch)
treeb87fc1639943a1dd368c25314a1eba5977bfd5a1 /recipes-extended/dpdk/dpdk-module_23.03.bb
parentcbbe321bc6c9d6721565813459833e3d57839c45 (diff)
downloadmeta-dpdk-1a78228cf3c07f8166c4c2a317331ca8f1477906.tar.gz
dpdk-module: upgrade 22.07.0 -> 23.03
Refresh patch to fix following build error in dpdk-module: ~build/tmp-glibc/work/intel_skylake_64-oe-linux/dpdk-module/23.03-r0/git/kernel/linux/kni/kni_net.c:22:10: fatal error: rte_kni_common.h: No such file or directory Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-extended/dpdk/dpdk-module_23.03.bb')
-rw-r--r--recipes-extended/dpdk/dpdk-module_23.03.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk-module_23.03.bb b/recipes-extended/dpdk/dpdk-module_23.03.bb
new file mode 100644
index 0000000..b8f6c95
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-module_23.03.bb
@@ -0,0 +1,58 @@
1include dpdk.inc
2
3FILESEXTRAPATHS:prepend := "${THISDIR}/dpdk:"
4
5SRC_URI = "git://dpdk.org/git/dpdk;branch=${BRANCH};protocol=https \
6 file://0001-Makefile-add-makefile.patch \
7"
8
9BRANCH = "releases"
10SRCREV = "189c02f5ec891ed02927062e124e8ca03adf74e7"
11S = "${WORKDIR}/git"
12
13inherit module
14
15#kernel module needs 'rte_build_config.h', which is generated at buid time
16DEPENDS += "dpdk"
17
18COMPATIBLE_MACHINE = "null"
19COMPATIBLE_HOST:libc-musl:class-target = "null"
20COMPATIBLE_HOST:linux-gnux32 = "null"
21
22export S
23export STAGING_KERNEL_DIR
24export STAGING_INCDIR
25export INSTALL_MOD_DIR="dpdk"
26
27do_configure[noexec] = "1"
28
29do_compile() {
30 cd ${S}/kernel/linux/kni
31 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
32 oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
33 KERNEL_VERSION=${KERNEL_VERSION} \
34 CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
35 AR="${KERNEL_AR}" \
36 O=${STAGING_KERNEL_BUILDDIR} \
37 KBUILD_EXTRA_SYMBOLS="${KBUILD_EXTRA_SYMBOLS}" \
38 ${MAKE_TARGETS}
39}
40
41do_install() {
42 cd ${S}/kernel/linux/kni
43 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
44 oe_runmake DEPMOD=echo MODLIB="${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}" \
45 INSTALL_FW_PATH="${D}${nonarch_base_libdir}/firmware" \
46 CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
47 O=${STAGING_KERNEL_BUILDDIR} \
48 ${MODULES_INSTALL_TARGET}
49}
50
51# CVE-2021-3839 has been fixed by commit 4c40d30d2b in 21.11.1
52# NVD database is incomplete
53# CVE-2022-0669 has been fixed by commit 6cb68162e4 in 21.11.1
54# NVD database is incomplete
55CVE_CHECK_IGNORE += "\
56 CVE-2021-3839 \
57 CVE-2022-0669 \
58"