summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-04-15 18:51:34 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-16 09:03:18 +0800
commitd4ddaf2e54b8d7ef7096208430b3f5363d849bea (patch)
tree8e9c426ab423aa946857171e92dc670dcaddd17e
parentd511c4260b932329b14ed7ffe683d63d4f224716 (diff)
downloadmeta-dpdk-d4ddaf2e54b8d7ef7096208430b3f5363d849bea.tar.gz
dpdk/20.11: add recipe
kernel module is provided using seperate dpdk-module recipe. Release notes: https://doc.dpdk.org/guides-20.11/rel_notes/release_20_11.html Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch38
-rw-r--r--recipes-extended/dpdk/dpdk_20.11.1.bb64
2 files changed, 102 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch b/recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch
new file mode 100644
index 0000000..bef1f45
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch
@@ -0,0 +1,38 @@
1From cf8f15824dc2dd306d9c7e111641bef045d623c2 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 14 Apr 2021 16:03:10 +0800
4Subject: [PATCH] meson.build:-march and -mcpu already passed by Yocto
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 config/meson.build | 12 ++++++------
11 1 file changed, 6 insertions(+), 6 deletions(-)
12
13diff --git a/config/meson.build b/config/meson.build
14index 2f150de3b8..41bb3e9ec4 100644
15--- a/config/meson.build
16+++ b/config/meson.build
17@@ -94,12 +94,12 @@ dpdk_conf.set('RTE_MACHINE', machine)
18 machine_args = []
19
20 # ppc64 does not support -march= at all, use -mcpu and -mtune for that
21-if host_machine.cpu_family().startswith('ppc')
22- machine_args += '-mcpu=' + machine
23- machine_args += '-mtune=' + machine
24-else
25- machine_args += '-march=' + machine
26-endif
27+#if host_machine.cpu_family().startswith('ppc')
28+# machine_args += '-mcpu=' + machine
29+# machine_args += '-mtune=' + machine
30+#else
31+# machine_args += '-march=' + machine
32+#endif
33
34 toolchain = cc.get_id()
35 dpdk_conf.set_quoted('RTE_TOOLCHAIN', toolchain)
36--
372.17.1
38
diff --git a/recipes-extended/dpdk/dpdk_20.11.1.bb b/recipes-extended/dpdk/dpdk_20.11.1.bb
new file mode 100644
index 0000000..7b0f0ee
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_20.11.1.bb
@@ -0,0 +1,64 @@
1include dpdk.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch \
5"
6
7STABLE = "-stable"
8BRANCH = "20.11"
9SRCREV = "b1e71cf43153cca07db6cbb69fdca030ccf52234"
10S = "${WORKDIR}/git"
11
12# kernel module is provide by dpdk-module recipe, so disable here
13EXTRA_OEMESON = " -Denable_kmods=false \
14 -Dexamples=all \
15"
16
17COMPATIBLE_MACHINE = "null"
18COMPATIBLE_HOST_libc-musl_class-target = "null"
19COMPATIBLE_HOST_linux-gnux32 = "null"
20
21RDEPENDS_${PN} += "pciutils python3-core"
22RDEPENDS_${PN}-examples += "bash"
23DEPENDS = "numactl"
24
25inherit meson
26
27INSTALL_PATH = "${prefix}/share/dpdk"
28
29do_install_append(){
30 # remove source files
31 rm -rf ${D}/${INSTALL_PATH}/examples/*
32
33 # Install examples
34 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
35 for dirname in ${B}/examples/dpdk-*
36 do
37 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
38 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
39 fi
40 done
41
42}
43
44PACKAGES =+ "${PN}-examples ${PN}-tools"
45
46FILES_${PN} = " ${bindir}/dpdk-testpmd \
47 ${bindir}/dpdk-proc-info \
48 ${libdir}/*.so* \
49 ${libdir}/dpdk/pmds-21.0/*.so* \
50 "
51FILES_${PN}-examples = " \
52 ${prefix}/share/dpdk/examples/* \
53 "
54
55FILES_${PN}-tools = " \
56 ${bindir}/dpdk-pdump \
57 ${bindir}/dpdk-test \
58 ${bindir}/dpdk-test-* \
59 ${bindir}/dpdk-*.py \
60 "
61
62CVE_PRODUCT = "data_plane_development_kit"
63
64INSANE_SKIP_${PN} = "dev-so"