summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2022-05-06 17:55:41 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-05-06 19:05:16 +0800
commitad5fdb707f44dddd276b864d2098c3abede90067 (patch)
tree8b83a04bd2ba1a5b690bfecc086598367065c745
parent6d1f4657c85c36fcb16cbc309e486c7248e03964 (diff)
downloadmeta-dpdk-ad5fdb707f44dddd276b864d2098c3abede90067.tar.gz
dpdk/20.11: update to v20.11.5
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk-module_20.11.5.bb (renamed from recipes-extended/dpdk/dpdk-module_20.11.1.bb)2
-rw-r--r--recipes-extended/dpdk/dpdk/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch35
-rw-r--r--recipes-extended/dpdk/dpdk_20.11.5.bb (renamed from recipes-extended/dpdk/dpdk_20.11.1.bb)3
3 files changed, 2 insertions, 38 deletions
diff --git a/recipes-extended/dpdk/dpdk-module_20.11.1.bb b/recipes-extended/dpdk/dpdk-module_20.11.5.bb
index 42fe229..64defa8 100644
--- a/recipes-extended/dpdk/dpdk-module_20.11.1.bb
+++ b/recipes-extended/dpdk/dpdk-module_20.11.5.bb
@@ -8,7 +8,7 @@ SRC_URI += " \
8" 8"
9STABLE = "-stable" 9STABLE = "-stable"
10BRANCH = "20.11" 10BRANCH = "20.11"
11SRCREV = "b1e71cf43153cca07db6cbb69fdca030ccf52234" 11SRCREV = "abf68ccc8b1f923f0eb0b6bf2a8b944378e1ebeb"
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit module 14inherit module
diff --git a/recipes-extended/dpdk/dpdk/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch b/recipes-extended/dpdk/dpdk/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch
deleted file mode 100644
index 4df28c4..0000000
--- a/recipes-extended/dpdk/dpdk/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 308409d72671b7978b20d40748ad985a235b6c86 Mon Sep 17 00:00:00 2001
2From: Mohamad Noor Alim Hussin <mohamad.noor.alim.hussin@intel.com>
3Date: Thu, 24 Jun 2021 11:30:09 +0800
4Subject: [PATCH] ifpga/meson: Fix finding librt using find_library()
5
6Finding with "librt" keyword would give the output
7with full path of librt such as /usr/lib/librt.so
8instead of -lrt.
9
10Assume find_library() will prepend "lib", thus remove
11"lib" from "librt" keyword. The output will shows as
12-lrt.
13
14Upstream-Status: Submitted [https://mails.dpdk.org/archives/stable/2021-June/031840.html]
15
16Signed-off-by: Mohamad Noor Alim Hussin <mohamad.noor.alim.hussin@intel.com>
17---
18 drivers/raw/ifpga/base/meson.build | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/drivers/raw/ifpga/base/meson.build b/drivers/raw/ifpga/base/meson.build
22index da2d6e33c..949f7f127 100644
23--- a/drivers/raw/ifpga/base/meson.build
24+++ b/drivers/raw/ifpga/base/meson.build
25@@ -25,7 +25,7 @@ sources = [
26
27 rtdep = dependency('librt', required: false)
28 if not rtdep.found()
29- rtdep = cc.find_library('librt', required: false)
30+ rtdep = cc.find_library('rt', required: false)
31 endif
32 if not rtdep.found()
33 build = false
34--
352.32.0
diff --git a/recipes-extended/dpdk/dpdk_20.11.1.bb b/recipes-extended/dpdk/dpdk_20.11.5.bb
index 061ed8e..1e537f5 100644
--- a/recipes-extended/dpdk/dpdk_20.11.1.bb
+++ b/recipes-extended/dpdk/dpdk_20.11.5.bb
@@ -2,12 +2,11 @@ include dpdk.inc
2 2
3SRC_URI += " \ 3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch \ 4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch \
5 file://0001-ifpga-meson-Fix-finding-librt-using-find_library.patch \
6" 5"
7 6
8STABLE = "-stable" 7STABLE = "-stable"
9BRANCH = "20.11" 8BRANCH = "20.11"
10SRCREV = "b1e71cf43153cca07db6cbb69fdca030ccf52234" 9SRCREV = "abf68ccc8b1f923f0eb0b6bf2a8b944378e1ebeb"
11S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
12 11
13# kernel module is provide by dpdk-module recipe, so disable here 12# kernel module is provide by dpdk-module recipe, so disable here