summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-04-20 09:56:37 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-04-20 10:05:38 +0800
commita84fef2b5f249dd4a5e61efb62a0f568a23101e2 (patch)
treeec08ed59f335b932041fa3368c7cbf40d6b0ada0
parentb11f6044df7a6fded025975675b385d44bb0d52d (diff)
downloadmeta-dpdk-a84fef2b5f249dd4a5e61efb62a0f568a23101e2.tar.gz
dpdk/19.11: upgrade 19.11.0 -> 19.11.1
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch57
-rw-r--r--recipes-extended/dpdk/dpdk_19.11.1.bb (renamed from recipes-extended/dpdk/dpdk_19.11.0.bb)6
2 files changed, 3 insertions, 60 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch b/recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch
deleted file mode 100644
index 28897cb..0000000
--- a/recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1From 38ad54f3bc7614b53bd6ca3644a471a3842502fc Mon Sep 17 00:00:00 2001
2From: Ferruh Yigit <ferruh.yigit@intel.com>
3Date: Wed, 12 Feb 2020 17:14:24 +0000
4Subject: [PATCH] kni: fix build with Linux 5.6
5
6With the following Linux commit a new parameter 'txqueue' has been added
7to 'ndo_tx_timeout' ndo:
8commit 0290bd291cc0 ("netdev: pass the stuck queue to the timeout handler")
9
10The change reflected to the KNI with version check.
11
12Cc: stable@dpdk.org
13
14Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
15Acked-by: David Marchand <david.marchand@redhat.com>
16
17Upstream-Status: Backport [38ad54f3bc7614b53bd6ca3644a471a3842502fc]
18
19Signed-off-by: He Zhe <zhe.he@windriver.com>
20---
21 kernel/linux/kni/compat.h | 4 ++++
22 kernel/linux/kni/kni_net.c | 5 +++++
23 2 files changed, 9 insertions(+)
24
25diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
26index 7109474..9ee45db 100644
27--- a/kernel/linux/kni/compat.h
28+++ b/kernel/linux/kni/compat.h
29@@ -130,3 +130,7 @@
30 #if KERNEL_VERSION(4, 10, 0) <= LINUX_VERSION_CODE
31 #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
32 #endif
33+
34+#if KERNEL_VERSION(5, 6, 0) <= LINUX_VERSION_CODE
35+#define HAVE_TX_TIMEOUT_TXQUEUE
36+#endif
37diff --git a/kernel/linux/kni/kni_net.c b/kernel/linux/kni/kni_net.c
38index 97fe85b..c82c881 100644
39--- a/kernel/linux/kni/kni_net.c
40+++ b/kernel/linux/kni/kni_net.c
41@@ -623,8 +623,13 @@ kni_net_rx(struct kni_dev *kni)
42 /*
43 * Deal with a transmit timeout.
44 */
45+#ifdef HAVE_TX_TIMEOUT_TXQUEUE
46+static void
47+kni_net_tx_timeout(struct net_device *dev, unsigned int txqueue)
48+#else
49 static void
50 kni_net_tx_timeout(struct net_device *dev)
51+#endif
52 {
53 pr_debug("Transmit timeout at %ld, latency %ld\n", jiffies,
54 jiffies - dev_trans_start(dev));
55--
562.7.4
57
diff --git a/recipes-extended/dpdk/dpdk_19.11.0.bb b/recipes-extended/dpdk/dpdk_19.11.1.bb
index 9046ae1..1ac1a93 100644
--- a/recipes-extended/dpdk/dpdk_19.11.0.bb
+++ b/recipes-extended/dpdk/dpdk_19.11.1.bb
@@ -3,15 +3,15 @@ include dpdk.inc
3CONFIG_NAME = "common_linux" 3CONFIG_NAME = "common_linux"
4TEST_DIR = "app/test" 4TEST_DIR = "app/test"
5 5
6SRCREV = "7001c8fdb27357c67147c0a13cb3826e48c0f2bf" 6STABLE = "-stable"
7BRANCH = "19.11"
8SRCREV = "622b78505c37571bdceaf0166012095ce08e2b28"
7 9
8LICENSE = "BSD-3-Clause & LGPLv2.1 & GPLv2" 10LICENSE = "BSD-3-Clause & LGPLv2.1 & GPLv2"
9LIC_FILES_CHKSUM = "file://license/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 11LIC_FILES_CHKSUM = "file://license/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://license/lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \ 12 file://license/lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \
11 file://license/bsd-3-clause.txt;md5=0f00d99239d922ffd13cabef83b33444" 13 file://license/bsd-3-clause.txt;md5=0f00d99239d922ffd13cabef83b33444"
12 14
13SRC_URI += "file://0001-kni-fix-build-with-Linux-5.6.patch"
14
15do_install_append () { 15do_install_append () {
16 # Remove the unneeded dir 16 # Remove the unneeded dir
17 rm -rf ${D}/${INSTALL_PATH}/${RTE_TARGET}/app 17 rm -rf ${D}/${INSTALL_PATH}/${RTE_TARGET}/app