summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2022-10-25 11:33:12 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-10-25 14:37:48 +0800
commit590c01813e352f3e47dc927adda61599c355e4c4 (patch)
treeffed38bfbea3a9de8e54a9c4451f57464a0c343e
parent4557324dde2becb4d34bd1fac7130f72201fcea0 (diff)
downloadmeta-dpdk-590c01813e352f3e47dc927adda61599c355e4c4.tar.gz
dpdk/20.11: drop recipe
Recipe for dpdk 22.07 already has been added. So time to drop it. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk-module_20.11.6.bb49
-rw-r--r--recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch38
-rw-r--r--recipes-extended/dpdk/dpdk_20.11.6.bb68
3 files changed, 0 insertions, 155 deletions
diff --git a/recipes-extended/dpdk/dpdk-module_20.11.6.bb b/recipes-extended/dpdk/dpdk-module_20.11.6.bb
deleted file mode 100644
index 29b055d..0000000
--- a/recipes-extended/dpdk/dpdk-module_20.11.6.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1include dpdk.inc
2
3FILESEXTRAPATHS:prepend := "${THISDIR}/dpdk:"
4
5SRC_URI += " \
6 file://0001-Makefile-add-makefile.patch \
7"
8STABLE = "-stable"
9BRANCH = "20.11"
10SRCREV = "73655c6414914c99a33010e9e7bdae9cafd24404"
11S = "${WORKDIR}/git"
12
13inherit module
14
15#kernel module needs 'rte_build_config.h', which is generated at buid time
16DEPENDS += "dpdk"
17
18COMPATIBLE_MACHINE = "null"
19COMPATIBLE_HOST:libc-musl:class-target = "null"
20COMPATIBLE_HOST:linux-gnux32 = "null"
21
22export S
23export STAGING_KERNEL_DIR
24export STAGING_INCDIR
25export INSTALL_MOD_DIR="dpdk"
26
27do_configure[noexec] = "1"
28
29do_compile() {
30 cd ${S}/kernel/linux/kni
31 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
32 oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
33 KERNEL_VERSION=${KERNEL_VERSION} \
34 CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
35 AR="${KERNEL_AR}" \
36 O=${STAGING_KERNEL_BUILDDIR} \
37 KBUILD_EXTRA_SYMBOLS="${KBUILD_EXTRA_SYMBOLS}" \
38 ${MAKE_TARGETS}
39}
40
41do_install() {
42 cd ${S}/kernel/linux/kni
43 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
44 oe_runmake DEPMOD=echo MODLIB="${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}" \
45 INSTALL_FW_PATH="${D}${nonarch_base_libdir}/firmware" \
46 CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
47 O=${STAGING_KERNEL_BUILDDIR} \
48 ${MODULES_INSTALL_TARGET}
49}
diff --git a/recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch b/recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch
deleted file mode 100644
index bef1f45..0000000
--- a/recipes-extended/dpdk/dpdk/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From cf8f15824dc2dd306d9c7e111641bef045d623c2 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 14 Apr 2021 16:03:10 +0800
4Subject: [PATCH] meson.build:-march and -mcpu already passed by Yocto
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 config/meson.build | 12 ++++++------
11 1 file changed, 6 insertions(+), 6 deletions(-)
12
13diff --git a/config/meson.build b/config/meson.build
14index 2f150de3b8..41bb3e9ec4 100644
15--- a/config/meson.build
16+++ b/config/meson.build
17@@ -94,12 +94,12 @@ dpdk_conf.set('RTE_MACHINE', machine)
18 machine_args = []
19
20 # ppc64 does not support -march= at all, use -mcpu and -mtune for that
21-if host_machine.cpu_family().startswith('ppc')
22- machine_args += '-mcpu=' + machine
23- machine_args += '-mtune=' + machine
24-else
25- machine_args += '-march=' + machine
26-endif
27+#if host_machine.cpu_family().startswith('ppc')
28+# machine_args += '-mcpu=' + machine
29+# machine_args += '-mtune=' + machine
30+#else
31+# machine_args += '-march=' + machine
32+#endif
33
34 toolchain = cc.get_id()
35 dpdk_conf.set_quoted('RTE_TOOLCHAIN', toolchain)
36--
372.17.1
38
diff --git a/recipes-extended/dpdk/dpdk_20.11.6.bb b/recipes-extended/dpdk/dpdk_20.11.6.bb
deleted file mode 100644
index db585d5..0000000
--- a/recipes-extended/dpdk/dpdk_20.11.6.bb
+++ /dev/null
@@ -1,68 +0,0 @@
1include dpdk.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch \
5"
6
7STABLE = "-stable"
8BRANCH = "20.11"
9SRCREV = "73655c6414914c99a33010e9e7bdae9cafd24404"
10S = "${WORKDIR}/git"
11
12# kernel module is provide by dpdk-module recipe, so disable here
13EXTRA_OEMESON = " -Denable_kmods=false \
14 -Dexamples=all \
15"
16
17COMPATIBLE_MACHINE = "null"
18COMPATIBLE_HOST:libc-musl:class-target = "null"
19COMPATIBLE_HOST:linux-gnux32 = "null"
20
21PACKAGECONFIG ??= " "
22PACKAGECONFIG[afxdp] = ",,libbpf"
23PACKAGECONFIG[libvirt] = ",,libvirt"
24
25RDEPENDS:${PN} += "pciutils python3-core"
26RDEPENDS:${PN}-examples += "bash"
27DEPENDS = "numactl"
28
29inherit meson
30
31INSTALL_PATH = "${prefix}/share/dpdk"
32
33do_install:append(){
34 # remove source files
35 rm -rf ${D}/${INSTALL_PATH}/examples/*
36
37 # Install examples
38 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
39 for dirname in ${B}/examples/dpdk-*
40 do
41 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
42 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
43 fi
44 done
45
46}
47
48PACKAGES =+ "${PN}-examples ${PN}-tools"
49
50FILES:${PN} = " ${bindir}/dpdk-testpmd \
51 ${bindir}/dpdk-proc-info \
52 ${libdir}/*.so* \
53 ${libdir}/dpdk/pmds-21.0/*.so* \
54 "
55FILES:${PN}-examples = " \
56 ${prefix}/share/dpdk/examples/* \
57 "
58
59FILES:${PN}-tools = " \
60 ${bindir}/dpdk-pdump \
61 ${bindir}/dpdk-test \
62 ${bindir}/dpdk-test-* \
63 ${bindir}/dpdk-*.py \
64 "
65
66CVE_PRODUCT = "data_plane_development_kit"
67
68INSANE_SKIP:${PN} = "dev-so"