summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2023-02-07 09:39:40 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-02-07 09:52:17 +0800
commit42608b107a1786ca3e7fc807be3f8b1280108d28 (patch)
tree0aca70a98a4f8016c108b95f0c4498fa87a9c6bf
parent6e3c19f73598f0cff6a160513ba23700cb4b3556 (diff)
downloadmeta-dpdk-42608b107a1786ca3e7fc807be3f8b1280108d28.tar.gz
xdp-tools: build static library
The problem with shared library is that generated object files are also required additionally by libxdp. So build the static library instead of installing .o files as well (which would need us to disable stripping etc.) Error log while building libxdp: | libxdp: Couldn't find a BPF file with name xsk_def_xdp_prog.o | xsk_configure(): Failed to create xsk socket Enable production option too. Also see: https://github.com/xdp-project/xdp-tools/issues/180 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb
index 99c435d..7cd49a0 100644
--- a/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb
+++ b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb
@@ -21,13 +21,11 @@ S = "${WORKDIR}/git"
21 21
22inherit pkgconfig 22inherit pkgconfig
23 23
24EXTRA_OEMAKE += "PREFIX=${D}${prefix} LIBDIR=${D}${libdir}" 24EXTRA_OEMAKE += "PREFIX=${D}${prefix} LIBDIR=${D}${libdir} BUILD_STATIC_ONLY=1 PRODUCTION=1"
25 25
26export STAGING_INCDIR 26CFLAGS += "-fPIC"
27 27
28do_configure:prepend () { 28export STAGING_INCDIR
29 export DYNAMIC_LIBXDP=1
30}
31 29
32do_install () { 30do_install () {
33 oe_runmake install 31 oe_runmake install