summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYongxin Liu <yongxin.liu@windriver.com>2021-12-07 10:44:29 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-12-08 08:58:13 +0800
commit2fa997c389ec980de7f86b81eca28158ca6e27cd (patch)
treef0cdb6c04b39209d2652a11017019e39b7ba03d0
parent6c1b9b6cfe495ed5e62e1d2b8f75f24a790ee696 (diff)
downloadmeta-dpdk-2fa997c389ec980de7f86b81eca28158ca6e27cd.tar.gz
dpdk-module: replace random_ether_addr() with eth_random_addr()
random_ether_addr() is finally removed in kernel commit ba530fea8ca1 ("ethernet: remove random_ether_addr()"). Backport commit e6cbfd9bf30b ("kni: update kernel API to set random MAC address") from dpdk repo to use eth_random_addr() instead. Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk-module_20.11.1.bb1
-rw-r--r--recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch44
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk-module_20.11.1.bb b/recipes-extended/dpdk/dpdk-module_20.11.1.bb
index 1860087..85d708c 100644
--- a/recipes-extended/dpdk/dpdk-module_20.11.1.bb
+++ b/recipes-extended/dpdk/dpdk-module_20.11.1.bb
@@ -4,6 +4,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/dpdk:"
4 4
5SRC_URI += " \ 5SRC_URI += " \
6 file://0001-Makefile-add-makefile.patch \ 6 file://0001-Makefile-add-makefile.patch \
7 file://0002-kni-update-kernel-API-to-set-random-MAC-address.patch \
7" 8"
8STABLE = "-stable" 9STABLE = "-stable"
9BRANCH = "20.11" 10BRANCH = "20.11"
diff --git a/recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch b/recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch
new file mode 100644
index 0000000..dea9e12
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch
@@ -0,0 +1,44 @@
1From e0a23f3cf8410871d28fdd8f0806216848b357ce Mon Sep 17 00:00:00 2001
2From: Ferruh Yigit <ferruh.yigit@intel.com>
3Date: Wed, 3 Nov 2021 12:59:50 +0000
4Subject: [PATCH] kni: update kernel API to set random MAC address
5
6Previously used 'random_ether_addr()' API is removed in upstream kernel
7with commit
8Commit ba530fea8ca1 ("ethernet: remove random_ether_addr()")
9
10Replacement API 'eth_random_addr()' is around since v3.6 [1], so
11simply switching to this API without any version checks.
12
13[1]
140a4dd594982a ("etherdevice: Rename random_ether_addr to eth_random_addr")
15
16Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
17
18Upstream-Status: Backport [http://git.dpdk.org/dpdk/commit/?id=e6cbfd9bf30bbc4170fe8c7c04a16d9cf795fb90]
19Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com>
20---
21 kernel/linux/kni/kni_misc.c | 7 ++-----
22 1 file changed, 2 insertions(+), 5 deletions(-)
23
24diff --git a/kernel/linux/kni/kni_misc.c b/kernel/linux/kni/kni_misc.c
25index 2b464c4381..f4944e1ddf 100644
26--- a/kernel/linux/kni/kni_misc.c
27+++ b/kernel/linux/kni/kni_misc.c
28@@ -399,11 +399,8 @@ kni_ioctl_create(struct net *net, uint32_t ioctl_num,
29 if (is_valid_ether_addr(dev_info.mac_addr))
30 memcpy(net_dev->dev_addr, dev_info.mac_addr, ETH_ALEN);
31 else
32- /*
33- * Generate random mac address. eth_random_addr() is the
34- * newer version of generating mac address in kernel.
35- */
36- random_ether_addr(net_dev->dev_addr);
37+ /* Generate random MAC address. */
38+ eth_random_addr(net_dev->dev_addr);
39
40 if (dev_info.mtu)
41 net_dev->mtu = dev_info.mtu;
42--
432.32.0
44