summaryrefslogtreecommitdiffstats
path: root/recipes-support/openldap/openldap_2.4.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/openldap/openldap_2.4.39.bb')
-rw-r--r--recipes-support/openldap/openldap_2.4.39.bb182
1 files changed, 182 insertions, 0 deletions
diff --git a/recipes-support/openldap/openldap_2.4.39.bb b/recipes-support/openldap/openldap_2.4.39.bb
new file mode 100644
index 0000000..3048c8e
--- /dev/null
+++ b/recipes-support/openldap/openldap_2.4.39.bb
@@ -0,0 +1,182 @@
1# OpenLDAP, a license free (see http://www.OpenLDAP.org/license.html)
2#
3DESCRIPTION = "OpenLDAP Software is an open source implementation of the Lightweight Directory Access Protocol."
4HOMEPAGE = "http://www.OpenLDAP.org/license.html"
5# The OpenLDAP Public License - see the HOMEPAGE - defines
6# the license. www.openldap.org claims this is Open Source
7# (see http://www.openldap.org), the license appears to be
8# basically BSD. opensource.org does not record this license
9# at present (so it is apparently not OSI certified).
10LICENSE = "OpenLDAP"
11LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f2bdbaa4f50199a00b6de2ca7ec1db05"
12SECTION = "libs"
13
14# patches taken from Debian
15SRC_URI = "\
16 ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${P}.tgz \
17 file://man-slapd.patch \
18 file://evolution-ntlm.patch \
19 file://slapi-errorlog-file.patch \
20 file://ldapi-socket-place.patch \
21 file://wrong-database-location.patch \
22 file://index-files-created-as-root.patch \
23 file://sasl-default-path.patch \
24 file://libldap-symbol-versions.patch \
25 file://getaddrinfo-is-threadsafe.patch \
26 file://do-not-second-guess-sonames.patch \
27 file://contrib-modules-use-dpkg-buildflags.patch \
28 file://smbk5pwd-makefile.patch \
29 file://autogroup-makefile.patch \
30 file://ldap-conf-tls-cacertdir.patch \
31 file://add-tlscacert-option-to-ldap-conf.patch \
32 file://fix-ftbfs-binutils-gold.patch \
33 file://fix-build-top-mk.patch \
34 file://no-AM_INIT_AUTOMAKE.patch \
35 file://switch-to-lt_dlopenadvise-to-get-RTLD_GLOBAL-set.diff.patch \
36 file://no-bdb-ABI-second-guessing.patch \
37 file://heimdal-fix.patch \
38"
39SRC_URI[md5sum] = "b0d5ee4b252c841dec6b332d679cf943"
40SRC_URI[sha256sum] = "8267c87347103fef56b783b24877c0feda1063d3cb85d070e503d076584bf8a7"
41
42DEPENDS = "util-linux groff-native db"
43
44PR = "r0"
45# The original top.mk used INSTALL, not INSTALL_STRIP_PROGRAM when
46# installing .so and executables, this fails in cross compilation
47# environments
48SRC_URI += "file://install-strip.patch"
49
50# inherit autotools
51inherit autotools-brokensep
52
53# CV SETTINGS
54# Required to work round AC_FUNC_MEMCMP which gets the wrong answer
55# when cross compiling (should be in site?)
56EXTRA_OECONF += "ac_cv_func_memcmp_working=yes"
57
58# CONFIG DEFINITIONS
59# The following is necessary because it cannot be determined for a
60# cross compile automagically. Select should yield fine on all OE
61# systems...
62EXTRA_OECONF += "--with-yielding-select=yes"
63# Shared libraries are nice...
64EXTRA_OECONF += "--enable-dynamic"
65
66PACKAGECONFIG ??= "openssl modules \
67 ldap meta monitor null passwd shell proxycache dnssrv \
68 bdb hdb mdb sasl \
69"
70#--with-tls with TLS/SSL support auto|openssl|gnutls [auto]
71PACKAGECONFIG[gnutls] = "--with-tls=gnutls,,gnutls"
72PACKAGECONFIG[openssl] = "--with-tls=openssl,,openssl"
73
74PACKAGECONFIG[sasl] = "--with-cyrus-sasl,--without-cyrus-sasl,cyrus-sasl"
75PACKAGECONFIG[modules] = "lt_cv_dlopen_self=yes --enable-modules,--disable-modules,libtool"
76
77# SLAPD options
78#
79# UNIX crypt(3) passwd support:
80EXTRA_OECONF += "--enable-crypt"
81
82EXTRA_OECONF += "--enable-ipv6"
83
84# SLAPD BACKEND
85#
86# The backend must be set by the configuration. This controls the
87# required database, the default database, bdb, is turned off but
88# can be turned back on again and it *is* below! The monitor backend
89# is also disabled. If you try to change the backends but fail to
90# enable a single one the build will fail in an obvious way.
91#
92# EXTRA_OECONF += "--disable-bdb --disable-hdb --disable-monitor"
93#
94# Backends="bdb dnssrv hdb ldap ldbm meta monitor null passwd perl shell sql"
95#
96# Note that multiple backends can be built. The ldbm backend requires a
97# build-time choice of database API. The bdb backend forces this to be
98# DB4. To use the gdbm (or other) API the Berkely database module must
99# be removed from the build.
100md = "${libexecdir}/openldap"
101#
102#--enable-bdb enable Berkeley DB backend no|yes|mod yes
103# The Berkely DB is the standard choice. This version of OpenLDAP requires
104# the version 4 implementation or better.
105PACKAGECONFIG[bdb] = "--enable-bdb=mod,--enable-bdb=no,db"
106
107#--enable-dnssrv enable dnssrv backend no|yes|mod no
108PACKAGECONFIG[dnssrv] = "--enable-dnssrv=mod,--enable-dnssrv=no"
109
110#--enable-hdb enable Hierarchical DB backend no|yes|mod no
111# This forces ldbm to use Berkeley too, remove to use gdbm
112PACKAGECONFIG[hdb] = "--enable-hdb=mod,--enable-hdb=no,db"
113
114#--enable-ldap enable ldap backend no|yes|mod no
115PACKAGECONFIG[ldap] = "--enable-ldap=mod,--enable-ldap=no,"
116
117#--enable-ldbm enable ldbm backend no|yes|mod no
118# ldbm requires further specification of the underlying database API, because
119# bdb is enabled above this must be set to berkeley, however the config
120# defaults this correctly so --with-ldbm-api is *not* set. The build will
121# fail if bdb is removed, but no database is built to provide the
122# support for ldbm
123# guide.html:<P>back-ldbm was both slow and unreliable. Its byzantine indexing code was prone to spontaneous corruption, as were the underlying database libraries that were commonly used (e.g. GDBM or NDBM). back-bdb and back-hdb are superior in every aspect, with simplified indexing to avoid index corruption, fine-grained locking for greater concurrency, hierarchical caching for greater performance, streamlined on-disk format for greater efficiency and portability, and full transaction support for greater reliability.</P>
124# configure: WARNING: unrecognized options: --disable-silent-rules, --enable-ldbm, --with-ldbm-api
125#PACKAGECONFIG[ldbm] = "--enable-ldbm=mod --with-ldbm-api=gdbm,--enable-ldbm-no,gdbm"
126
127#--enable-meta enable metadirectory backend no|yes|mod no
128PACKAGECONFIG[meta] = "--enable-meta=mod,--enable-meta=no,"
129
130#--enable-monitor enable monitor backend no|yes|mod yes
131PACKAGECONFIG[monitor] = "--enable-monitor=mod,--enable-monitor=no,"
132
133#--enable-null enable null backend no|yes|mod no
134PACKAGECONFIG[null] = "--enable-null=mod,--enable-null=no,"
135
136#--enable-passwd enable passwd backend no|yes|mod no
137PACKAGECONFIG[passwd] = "--enable-passwd=mod,--enable-passwd=no,"
138
139# disabling perl support - host contamination issues
140#
141#--enable-perl enable perl backend no|yes|mod no
142# This requires a loadable perl dynamic library, if enabled without
143# doing something appropriate (building perl?) the build will pick
144# up the build machine perl - not good (inherit perlnative?)
145# PACKAGECONFIG[perl] = "--enable-perl=mod,--enable-perl=no,perl"
146
147#--enable-shell enable shell backend no|yes|mod no
148# configure: WARNING: Use of --without-threads is recommended with back-shell
149PACKAGECONFIG[shell] = "--enable-shell=mod --without-threads,--enable-shell=no,"
150
151#--enable-sql enable sql backend no|yes|mod no
152# sql requires some sql backend which provides sql.h, sqlite* provides
153# sqlite.h (which may be compatible but hasn't been tried.)
154PACKAGECONFIG[sql] = "--enable-sql=mod,--enable-sql=no,sqlite3"
155
156#--enable-dyngroup Dynamic Group overlay no|yes|mod no
157# This is a demo, Proxy Cache defines init_module which conflicts with the
158# same symbol in dyngroup
159PACKAGECONFIG[dyngroup] = "--enable-dyngroup=mod,--enable-dyngroup=no,"
160
161#--enable-proxycache Proxy Cache overlay no|yes|mod no
162PACKAGECONFIG[proxycache] = "--enable-proxycache=mod,--enable-proxycache=no,"
163
164#--enable-mdb enable mdb database backend no|yes|mod no
165PACKAGECONFIG[mdb] = "--enable-mdb=mod,--enable-mdb=no,"
166
167CPPFLAGS_append = " -D_GNU_SOURCE"
168
169do_configure() {
170 cp ${STAGING_DATADIR_NATIVE}/libtool/config/ltmain.sh ${S}/build
171 rm -f ${S}/libtool
172 rm -f ${S}/libtool
173 aclocal
174 libtoolize --force --copy
175 gnu-configize
176 autoconf
177 oe_runconf
178}
179
180FILES_${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libexecdir}/openldap/*.a ${libexecdir}/openldap/*.la ${libexecdir}/openldap/*.so"
181FILES_${PN}-dbg += "${libexecdir}/openldap/.debug"
182