summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul/consul-migrate_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul/consul-migrate_git.bb')
-rw-r--r--recipes-connectivity/consul/consul-migrate_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul-migrate_git.bb b/recipes-connectivity/consul/consul-migrate_git.bb
new file mode 100644
index 0000000..4cc53b2
--- /dev/null
+++ b/recipes-connectivity/consul/consul-migrate_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Provides data migration for Consul server nodes"
2HOMEPAGE = "https://github.com/hashicorp/consul-migrate"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378"
5
6DEPENDS += "raft raft-boltdb raft-mdb"
7
8PKG_NAME = "github.com/hashicorp/consul-migrate"
9SRC_URI = "git://${PKG_NAME}.git"
10SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710"
11
12inherit golang
13
14SYSROOT_PREPROCESS_FUNCS += "consul_migrate_sysroot_preprocess"
15
16export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
17
18consul_migrate_sysroot_preprocess () {
19 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
20 cp -a ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
21 install -d ${SYSROOT_DESTDIR}${prefix}/bin
22 cp -a ${D}${prefix}/bin/* ${SYSROOT_DESTDIR}${prefix}/bin/
23}
24
25CLEANBROKEN = "1"
26INSANE_SKIP_${PN} = "ldflags"