summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-setuptools-git.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb18
3 files changed, 16 insertions, 20 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-setuptools-git.inc b/meta-openstack/recipes-devtools/python/python-setuptools-git.inc
deleted file mode 100644
index 18bc1dc..0000000
--- a/meta-openstack/recipes-devtools/python/python-setuptools-git.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "Plugin for setuptools that enables git integration"
2HOMEPAGE = "https://github.com/wichert/setuptools-git"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3775480a712fc46a69647678acb234cb"
6
7SRC_URI[md5sum] = "40b2ef7687a384ea144503c2e5bc67e2"
8SRC_URI[sha256sum] = "ff64136da01aabba76ae88b050e7197918d8b2139ccbf6144e14d472b9c40445"
9
10inherit pypi
11
12# conflicting file prevention
13do_install_append() {
14 rm -f ${D}${libdir}/python*/site-packages/site.py*
15}
16BBCLASSEXTEND = "native"
diff --git a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb
deleted file mode 100644
index 5dd6804..0000000
--- a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1inherit setuptools3
2require python-setuptools-git.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb b/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb
index 5dd6804..34b40de 100644
--- a/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb
+++ b/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1DESCRIPTION = "Plugin for setuptools that enables git integration"
2require python-setuptools-git.inc 2HOMEPAGE = "https://github.com/wichert/setuptools-git"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3775480a712fc46a69647678acb234cb"
6
7SRC_URI[md5sum] = "40b2ef7687a384ea144503c2e5bc67e2"
8SRC_URI[sha256sum] = "ff64136da01aabba76ae88b050e7197918d8b2139ccbf6144e14d472b9c40445"
9
10inherit setuptools3 pypi
11
12# conflicting file prevention
13do_install_append() {
14 rm -f ${D}${libdir}/python*/site-packages/site.py*
15}
16BBCLASSEXTEND = "native"