summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/salt/salt_3000.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/salt/salt_3000.bb')
-rw-r--r--meta-openstack/recipes-support/salt/salt_3000.bb159
1 files changed, 159 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/salt/salt_3000.bb b/meta-openstack/recipes-support/salt/salt_3000.bb
new file mode 100644
index 0000000..c2bc8da
--- /dev/null
+++ b/meta-openstack/recipes-support/salt/salt_3000.bb
@@ -0,0 +1,159 @@
1HOMEPAGE = "http://saltstack.com/"
2SECTION = "admin"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
5DEPENDS = "\
6 python3-msgpack \
7 python3-pyyaml \
8 python3-jinja2 \
9 python3-markupsafe \
10 python3-dateutil \
11 python3-pycrypto \
12 python3-pytest-salt \
13 python3-pyzmq \
14 python3-requests \
15"
16
17PACKAGECONFIG ??= "zeromq"
18PACKAGECONFIG[zeromq] = ",,python3-pyzmq python3-pycrypto,"
19PACKAGECONFIG[tcp] = ",,python3-pycrypto"
20
21SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \
22 file://set_python_location_hashbang.patch \
23"
24
25SRC_URI[md5sum] = "8084ef6f2a275b627ae364b9d562b4ff"
26SRC_URI[sha256sum] = "04fbc64933b375cbbefc9576bcc65167b74d5eec7f58e64d096d67529ea66500"
27
28
29SYSTEMD_AUTO_ENABLE_${PN}-master = "disable"
30SYSTEMD_AUTO_ENABLE_${PN}-minion = "disable"
31SYSTEMD_AUTO_ENABLE_${PN}-api = "disable"
32
33S = "${WORKDIR}/${PN}-${PV}"
34
35inherit setuptools3 systemd
36
37# Avoid a QA Warning triggered by the test package including a file
38# with a .a extension
39INSANE_SKIP_${PN}-tests += "staticdev"
40
41RDEPENDS_${PN} += "${PN}-api \
42 ${PN}-common \
43 ${PN}-master \
44 ${PN}-minion \
45 ${PN}-bash-completion \
46"
47
48# Note ${PN}-tests must be before ${PN}-common in the PACKAGES variable
49# in order for ${PN}-tests to own the correct FILES.
50PACKAGES += "\
51 ${PN}-api \
52 ${PN}-common \
53 ${PN}-master \
54 ${PN}-minion \
55 ${PN}-cloud \
56 ${PN}-syndic \
57 ${PN}-ssh \
58 ${PN}-bash-completion \
59 ${PN}-zsh-completion \
60"
61
62do_install_append() {
63 install -Dm644 ${S}/pkg/salt-common.logrotate ${D}${sysconfdir}/logrotate.d/${PN}
64 install -Dm644 ${S}/pkg/salt.bash ${D}${datadir}/bash-completion/completions/${PN}
65 install -Dm644 ${S}/pkg/zsh_completion.zsh ${D}${datadir}/zsh/site-functions/_${PN}
66
67 # default config
68 install -Dm644 ${S}/conf/minion ${D}${sysconfdir}/${PN}/minion
69 install -Dm644 ${S}/conf/minion ${D}${sysconfdir}/${PN}/master
70
71 # systemd services
72 for _svc in salt-master.service salt-syndic.service salt-minion.service salt-api.service; do
73 install -Dm644 ${S}/pkg/$_svc "${D}${systemd_system_unitdir}/$_svc"
74 done
75}
76
77ALLOW_EMPTY_${PN} = "1"
78FILES_${PN} = ""
79FILES_${PN} += "${systemd_system_unitdir} ${systemd_system_unitdir}/* /etc/salt/master.d /etc/salt/master.d/preseed_key.py"
80
81DESCRIPTION_COMMON = "salt is a powerful remote execution manager that can be used to administer servers in a\
82 fast and efficient way. It allows commands to be executed across large groups of servers. This means systems\
83 can be easily managed, but data can also be easily gathered. Quick introspection into running systems becomes\
84 a reality. Remote execution is usually used to set up a certain state on a remote system. Salt addresses this\
85 problem as well, the salt state system uses salt state files to define the state a server needs to be in. \
86Between the remote execution system, and state management Salt addresses the backbone of cloud and data center\
87 management."
88
89SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system"
90DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt."
91RDEPENDS_${PN}-minion = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
92RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
93RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
94RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode"
95RSUGGESTS_${PN}-minion = "python3-augeas"
96CONFFILES_${PN}-minion = "${sysconfdir}/${PN}/minion"
97FILES_${PN}-minion = "${bindir}/${PN}-minion ${sysconfdir}/${PN}/minion.d/ ${CONFFILES_${PN}-minion} ${bindir}/${PN}-proxy ${systemd_system_unitdir}/salt-minion.service"
98
99SUMMARY_${PN}-common = "shared libraries that salt requires for all packages"
100DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \
101salt-master, salt-minion, and salt-syndic require to function."
102RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0)"
103RRECOMMENDS_${PN}-common = "lsb"
104RSUGGESTS_${PN}-common = "python3-mako python3-git"
105RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)"
106CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}"
107FILES_${PN}-common = "${bindir}/${PN}-call ${libdir}/python3.7/ ${CONFFILES_${PN}-common}"
108
109SUMMARY_${PN}-ssh = "remote manager to administer servers via salt"
110DESCRIPTION_${PN}-ssh = "${DESCRIPTION_COMMON} This particular package provides the salt ssh controller. It \
111is able to run salt modules and states on remote hosts via ssh. No minion or other salt specific software needs\
112 to be installed on the remote host."
113RDEPENDS_${PN}-ssh = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
114CONFFILES_${PN}-ssh="${sysconfdir}/${PN}/roster"
115FILES_${PN}-ssh = "${bindir}/${PN}-ssh ${CONFFILES_${PN}-ssh}"
116
117SUMMARY_${PN}-api = "generic, modular network access system"
118DESCRIPTION_${PN}-api = "a modular interface on top of Salt that can provide a variety of entry points into a \
119running Salt system. It can start and manage multiple interfaces allowing a REST API to coexist with XMLRPC or \
120even a Websocket API. The Salt API system is used to expose the fundamental aspects of Salt control to external\
121 sources. salt-api acts as the bridge between Salt itself and REST, Websockets, etc. Documentation is available\
122 on Read the Docs: http://salt-api.readthedocs.org/"
123RDEPENDS_${PN}-api = "${PN}-master"
124RSUGGESTS_${PN}-api = "python3-cherrypy"
125CONFFILES_${PN}-api = "${sysconfdir}/init.d/${PN}-api"
126FILES_${PN}-api = "${bindir}/${PN}-api ${CONFFILES_${PN}-api} ${systemd_system_unitdir}/${PN}-api.service"
127
128
129SUMMARY_${PN}-master = "remote manager to administer servers via salt"
130DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller."
131RDEPENDS_${PN}-master = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
132RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
133RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
134CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master"
135RSUGGESTS_${PN}-master = "python3-git"
136FILES_${PN}-master = "${bindir}/${PN} ${bindir}/${PN}-cp ${bindir}/${PN}-key ${bindir}/${PN}-master ${bindir}/${PN}-run ${bindir}/${PN}-unity ${bindir}/spm ${CONFFILES_${PN}-master} ${systemd_system_unitdir}/${PN}-master.service"
137
138
139SUMMARY_${PN}-syndic = "master-of-masters for salt, the distributed remote execution system"
140DESCRIPTION_${PN}-syndic = "${DESCRIPTION_COMMON} This particular package provides the master of masters for \
141salt; it enables the management of multiple masters at a time."
142RDEPENDS_${PN}-syndic = "${PN}-master (= ${EXTENDPKGV})"
143CONFFILES_${PN}-syndic="${sysconfdir}/init.d/${PN}-syndic"
144FILES_${PN}-syndic = "${bindir}/${PN}-syndic ${CONFFILES_${PN}-syndic} ${systemd_system_unitdir}/${PN}-syndic.service"
145
146SUMMARY_${PN}-cloud = "public cloud VM management system"
147DESCRIPTION_${PN}-cloud = "provision virtual machines on various public clouds via a cleanly controlled profile and mapping system."
148RDEPENDS_${PN}-cloud = "${PN}-common (= ${EXTENDPKGV})"
149RSUGGESTS_${PN}-cloud = "python3-netaddr python3-botocore"
150CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud"
151FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}"
152
153SUMMARY_${PN}-tests = "salt stack test suite"
154DESCRIPTION_${PN}-tests ="${DESCRIPTION_COMMON} This particular package provides the salt unit test suite."
155RDEPENDS_${PN}-tests = "${PN}-common python3-pytest-salt python3-tests python3-image bash"
156FILES_${PN}-tests = "${PYTHON_SITEPACKAGES_DIR}/salt-tests/tests/"
157
158FILES_${PN}-bash-completion = "${datadir}/bash-completion"
159FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"